summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-12-04 10:17:58 +0000
committerAli Polatel <hawking@gentoo.org>2007-12-04 10:17:58 +0000
commit4577ad5db15b0c7e0092000e95eeb53214b9dad2 (patch)
tree69be6bd0e41b49ee676c07780436be8616c12a86 /dev-python
parentDon't tamper with /etc/services. Fixes bug #195120. (diff)
downloadgentoo-2-4577ad5db15b0c7e0092000e95eeb53214b9dad2.tar.gz
gentoo-2-4577ad5db15b0c7e0092000e95eeb53214b9dad2.tar.bz2
gentoo-2-4577ad5db15b0c7e0092000e95eeb53214b9dad2.zip
Added patch to disable stripping, #199925
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog6
-rw-r--r--dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch32
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.1.ebuild9
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index 043be5819510..f6f4ec093151 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.2 2007/11/21 22:34:38 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.3 2007/12/04 10:17:58 hawking Exp $
+
+ 04 Dec 2007; Ali Polatel <hawking@gentoo.org>
+ +files/qscintilla-python-2.1-nostrip.patch, qscintilla-python-2.1.ebuild:
+ Added patch to disable stripping, #199925
21 Nov 2007; Ali Polatel <hawking@gentoo.org>
qscintilla-python-2.1.ebuild:
diff --git a/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch b/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch
new file mode 100644
index 000000000000..a689d868a922
--- /dev/null
+++ b/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch
@@ -0,0 +1,32 @@
+--- configure.py 2007-06-01 20:10:16.000000000 +0300
++++ configure.py 2007-12-04 11:51:56.000000000 +0200
+@@ -229,7 +229,8 @@
+ installs=installs,
+ static=opt_static,
+ debug=opt_debug,
+- universal=pyqt.universal
++ universal=pyqt.universal,
++ strip=0
+ )
+ elif pyqt.pyqt_version >= 0x040000:
+ makefile = pyqt4.QtGuiModuleMakefile(
+@@ -238,7 +239,8 @@
+ install_dir=opt_qscimoddir,
+ installs=installs,
+ static=opt_static,
+- debug=opt_debug
++ debug=opt_debug,
++ strip=0
+ )
+ else:
+ makefile = pyqt3.QtModuleMakefile(
+@@ -247,7 +249,8 @@
+ install_dir=opt_qscimoddir,
+ installs=installs,
+ static=opt_static,
+- debug=opt_debug
++ debug=opt_debug,
++ strip=0
+ )
+
+ makefile.extra_include_dirs.append(opt_qsciincdir)
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild
index d738ce9e0ee0..aba3d46c33df 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild,v 1.2 2007/11/21 22:34:38 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild,v 1.3 2007/12/04 10:17:58 hawking Exp $
inherit eutils python
@@ -41,6 +41,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+}
+
src_compile() {
local myconf="-o /usr/lib -n /usr/include"
if use qt4; then