summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-02 11:00:59 +0000
committerJustin Lecher <jlec@gentoo.org>2015-08-02 11:00:59 +0000
commit442308dc93959571d5a635b39d667a219fe6183e (patch)
tree2fbb86be6463ac7c374c0a76cddde81bc3c85419 /dev-python
parentBackport patch to work with recent cython version (diff)
downloadgentoo-2-442308dc93959571d5a635b39d667a219fe6183e.tar.gz
gentoo-2-442308dc93959571d5a635b39d667a219fe6183e.tar.bz2
gentoo-2-442308dc93959571d5a635b39d667a219fe6183e.zip
Dropl old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cython/ChangeLog7
-rw-r--r--dev-python/cython/cython-0.19.1-r1.ebuild59
-rw-r--r--dev-python/cython/cython-0.21.1.ebuild60
-rw-r--r--dev-python/cython/cython-0.21.2.ebuild62
-rw-r--r--dev-python/cython/cython-0.21.ebuild60
-rw-r--r--dev-python/cython/files/cython-0.20.1-backport-test-fix.patch13
6 files changed, 6 insertions, 255 deletions
diff --git a/dev-python/cython/ChangeLog b/dev-python/cython/ChangeLog
index 15d092bfcd00..2ab5e28f970e 100644
--- a/dev-python/cython/ChangeLog
+++ b/dev-python/cython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cython
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.159 2015/08/02 09:21:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.160 2015/08/02 11:00:59 jlec Exp $
+
+ 02 Aug 2015; Justin Lecher <jlec@gentoo.org> -cython-0.19.1-r1.ebuild,
+ -cython-0.21.1.ebuild, -cython-0.21.2.ebuild, -cython-0.21.ebuild,
+ -files/cython-0.20.1-backport-test-fix.patch:
+ Dropl old
02 Aug 2015; Pacho Ramos <pacho@gentoo.org> cython-0.21.1.ebuild:
sparc stable wrt bug #530280
diff --git a/dev-python/cython/cython-0.19.1-r1.ebuild b/dev-python/cython/cython-0.19.1-r1.ebuild
deleted file mode 100644
index 96b288aca401..000000000000
--- a/dev-python/cython/cython-0.19.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.19.1-r1.ebuild,v 1.14 2015/04/08 08:05:06 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-# Note: update numpy dep when it is fixed for py3.3.
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? (
- $(python_gen_cond_dep '>=dev-python/numpy-1.6.1-r1[${PYTHON_USEDEP}]' 'python*')
- )"
-
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS CXXFLAGS
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cython/cython-0.21.1.ebuild b/dev-python/cython/cython-0.21.1.ebuild
deleted file mode 100644
index 4c60080f8608..000000000000
--- a/dev-python/cython/cython-0.21.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.21.1.ebuild,v 1.10 2015/08/02 09:21:17 pacho Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*') )"
-
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cython/cython-0.21.2.ebuild b/dev-python/cython/cython-0.21.2.ebuild
deleted file mode 100644
index 32684a39530c..000000000000
--- a/dev-python/cython/cython-0.21.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.21.2.ebuild,v 1.2 2015/01/01 04:41:31 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-
-RDEPEND=""
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( Demos/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cython/cython-0.21.ebuild b/dev-python/cython/cython-0.21.ebuild
deleted file mode 100644
index eabbfa77107e..000000000000
--- a/dev-python/cython/cython-0.21.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.21.ebuild,v 1.15 2015/04/08 08:05:06 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*') )"
-
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cython/files/cython-0.20.1-backport-test-fix.patch b/dev-python/cython/files/cython-0.20.1-backport-test-fix.patch
deleted file mode 100644
index 4700c7b928ab..000000000000
--- a/dev-python/cython/files/cython-0.20.1-backport-test-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Cython/Debugger/Tests/TestLibCython.py b/Cython/Debugger/Tests/TestLibCython.py
-index 142c665..2f91096 100644
---- a/Cython/Debugger/Tests/TestLibCython.py
-+++ b/Cython/Debugger/Tests/TestLibCython.py
-@@ -124,6 +123,7 @@ def setUp(self):
- workdir=self.tempdir,
- # we clean up everything (not only compiled files)
- cleanup_workdir=False,
-+ tags=runtests.parse_tags(codefile),
- **opts
- )
-
-