summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-04 20:35:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-04 20:35:12 +0000
commit435f5980fe66c15fcef82887de510eefb2e82128 (patch)
treeb42854e8494f2ea386c7c60c00edafae5e219950 /dev-python
parentVersion bump #350549 by Timothy Miller. (diff)
downloadgentoo-2-435f5980fe66c15fcef82887de510eefb2e82128.tar.gz
gentoo-2-435f5980fe66c15fcef82887de510eefb2e82128.tar.bz2
gentoo-2-435f5980fe66c15fcef82887de510eefb2e82128.zip
Version bump.
(Portage version: 2.2.0_alpha12_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygments/ChangeLog10
-rw-r--r--dev-python/pygments/pygments-1.4.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/pygments/ChangeLog b/dev-python/pygments/ChangeLog
index 79bf58fa4827..f705565f43a8 100644
--- a/dev-python/pygments/ChangeLog
+++ b/dev-python/pygments/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygments
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.66 2010/12/18 19:50:42 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/ChangeLog,v 1.67 2011/01/04 20:35:12 arfrever Exp $
+
+*pygments-1.4 (04 Jan 2011)
+
+ 04 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pygments-1.4.ebuild:
+ Version bump.
18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pygments-1.3.1.ebuild:
diff --git a/dev-python/pygments/pygments-1.4.ebuild b/dev-python/pygments/pygments-1.4.ebuild
new file mode 100644
index 000000000000..40f14897fe8d
--- /dev/null
+++ b/dev-python/pygments/pygments-1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygments/pygments-1.4.ebuild,v 1.1 2011/01/04 20:35:12 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Pygments"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python."
+HOMEPAGE="http://pygments.org/ http://pypi.python.org/pypi/Pygments"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="test? (
+ dev-python/nose
+ virtual/ttf-fonts
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run.py
+ }
+ python_execute_function testing
+}
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/build || die "Installation of documentation failed"
+ fi
+}