summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 11:55:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-12 11:55:00 +0000
commit3f350408473a6fdac6f8283e095c085aaf8b94b9 (patch)
treecd916c4175d94fccca9897d6062de0cc15672b1f /dev-python
parentUse system sqlite (#252538). Depends on dev-db/sqlite[extensions] (diff)
downloadgentoo-2-3f350408473a6fdac6f8283e095c085aaf8b94b9.tar.gz
gentoo-2-3f350408473a6fdac6f8283e095c085aaf8b94b9.tar.bz2
gentoo-2-3f350408473a6fdac6f8283e095c085aaf8b94b9.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/Manifest1
-rw-r--r--dev-python/twisted/twisted-9.0.0.ebuild109
2 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index b673ccc19fab..bd5a697b317e 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -8,6 +8,5 @@ DIST TwistedCore-8.2.0.tar.bz2 1205654 RMD160 7162be0d4f131e2e8379ba4330b0ff8978
DIST TwistedCore-9.0.0.tar.bz2 1270053 RMD160 c71864bf174d4eaabfa1df2b579d6598ae8fe1a7 SHA1 6966ce9f481fccc6a8abfeec144314ba70e29b1c SHA256 6e71eeecf5c4fa5fd4ae1b2a3f907da69d62897eda02d23135ccf0ea36a2958e
EBUILD twisted-8.2.0-r2.ebuild 3531 RMD160 459a3e85be508bcb5ae4f9a31bc2e5dc98b919e6 SHA1 d9ca8274e80958d26824d34d17e9479b3779d31b SHA256 e1094525019fb2c5b9693ae2c4a058fb7467debbe3527c444c9139f022b3dc9f
EBUILD twisted-9.0.0-r1.ebuild 3832 RMD160 e262f984065fe784fc7a15b0067a38fcc8e192d2 SHA1 32b41f6a9b3d7775772574c20d1f20120c605715 SHA256 edfe58f6c87e4a609b882a1208e22b30a4e09057ab99d5b2357e637f0dd2d28a
-EBUILD twisted-9.0.0.ebuild 3564 RMD160 89eb0f2d2e34e1fd688fdb76286d67bc23b8d9b9 SHA1 d6591031d87e4c49f52b7dd8c8c7ee512f2b021e SHA256 9ba857f6723a590e9e37d17d751e6de002a6ae9a2135d4d5562bb925dd113356
MISC ChangeLog 20450 RMD160 dcf522a1138081046508a1dfb6fcaf8106fd1955 SHA1 92ad2d69a2e163f5527e541af499149ced7cf4f1 SHA256 11b42de0c9d9fcbff0ea7f49e7492c2ef5b0d490de8f297485cb00301981f87f
MISC metadata.xml 516 RMD160 3603e0b110b1486ed5c02ec37ccee6712e2098c8 SHA1 3fe53dc137c9bd5437e8f6fb1d397491f5e9281e SHA256 702ffca7fc318ecb382067e3bccf620bebd7da614430ea82de24445b9f75524c
diff --git a/dev-python/twisted/twisted-9.0.0.ebuild b/dev-python/twisted/twisted-9.0.0.ebuild
deleted file mode 100644
index b14d77e3f2bf..000000000000
--- a/dev-python/twisted/twisted-9.0.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-9.0.0.ebuild,v 1.4 2009/12/24 04:47:31 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils versionator
-
-MY_P="TwistedCore-${PV}"
-
-DESCRIPTION="An asynchronous networking framework written in Python"
-HOMEPAGE="http://www.twistedmatrix.com/ http://pypi.python.org/pypi/Twisted"
-SRC_URI="http://tmrc.mit.edu/mirror/${PN}/Core/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="crypt gtk serial"
-
-DEPEND=">=net-zope/zope-interface-3.0.1
- serial? ( dev-python/pyserial )
- crypt? ( >=dev-python/pyopenssl-0.5.1 )
- gtk? ( >=dev-python/pygtk-1.99 )
- !dev-python/twisted-docs"
-RDEPEND="${DEPEND}"
-
-RESTRICT_PYTHON_ABIS="3*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CREDITS NEWS README"
-
-src_prepare(){
- # Give a load-sensitive test a better chance of succeeding.
- epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
-
- # Pass valid arguments to "head" in the zsh completion function.
- epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with Python ${PYTHON_ABI}"
-
- pushd "${T}/tests$(python_get_sitedir)" > /dev/null || die
-
- # Skip broken tests.
- rm -f twisted/python/test/test_release.py
-
- # Prevent it from pulling in plugins from already installed twisted packages.
- rm -f twisted/plugins/__init__.py
-
- # An empty file doesn't work because the tests check for
- # docstrings in all packages
- echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
-
- PYTHONPATH=. "${T}/tests/usr/bin/trial" twisted || die "trial failed with Python ${PYTHON_ABI}"
-
- popd > /dev/null || die
- rm -fr "${T}/tests"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- python_generate_wrapper_scripts -E -f -q "${D%/}${EPREFIX}/usr/bin/trial"
-
- # get rid of this to prevent collision-protect from killing us. it
- # is regenerated in pkg_postinst.
- rm -f "${D%/}${EPREFIX}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
-
- # weird pattern to avoid installing the index.xhtml page
- doman doc/man/*.?
- insinto /usr/share/doc/${PF}
- doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
-
- newconfd "${FILESDIR}/twistd.conf" twistd
- newinitd "${FILESDIR}/twistd.init" twistd
-
- # zsh completion
- insinto /usr/share/zsh/site-functions/
- doins twisted/python/_twisted_zsh_stub
-}
-
-update_plugin_cache() {
- local tpath="${ROOT%/}${EPREFIX}$(python_get_sitedir)/twisted"
- # we have to remove the cache or removed plugins won't be removed
- # from the cache (http://twistedmatrix.com/bugs/issue926)
- [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
- if [[ -e "${tpath}/plugin.py" ]]; then
- # twisted is still installed, update.
- # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
- einfo "Regenerating plugin cache"
- "$(PYTHON)" -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- python_execute_function update_plugin_cache
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- python_execute_function update_plugin_cache
-}