summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-12-27 18:04:51 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-12-27 18:04:51 +0000
commit3ec79e54d62f9e9c11a835144b1fb6d5a90f801d (patch)
tree657bfcf4475134276996e8a923abb2020ffb414a /dev-python
parenttypo (diff)
downloadgentoo-2-3ec79e54d62f9e9c11a835144b1fb6d5a90f801d.tar.gz
gentoo-2-3ec79e54d62f9e9c11a835144b1fb6d5a90f801d.tar.bz2
gentoo-2-3ec79e54d62f9e9c11a835144b1fb6d5a90f801d.zip
remove automagic dependency on libffi, bug #198875
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog8
-rw-r--r--dev-python/pygobject/files/digest-pygobject-2.14.0-r13
-rw-r--r--dev-python/pygobject/files/pygobject-2.14.0-libffi-magic.patch40
-rw-r--r--dev-python/pygobject/pygobject-2.14.0-r1.ebuild80
4 files changed, 130 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index e7b908206ec7..200e90345900 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.29 2007/11/27 03:39:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.30 2007/12/27 18:04:50 eva Exp $
+
+*pygobject-2.14.0-r1 (27 Dec 2007)
+
+ 27 Dec 2007; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pygobject-2.14.0-libffi-magic.patch, +pygobject-2.14.0-r1.ebuild:
+ remove automagic dependency on libffi, bug #198875
27 Nov 2007; Jeroen Roovers <jer@gentoo.org> pygobject-2.14.0.ebuild:
Stable for HPPA (bug #199322).
diff --git a/dev-python/pygobject/files/digest-pygobject-2.14.0-r1 b/dev-python/pygobject/files/digest-pygobject-2.14.0-r1
new file mode 100644
index 000000000000..0192ff4bbc8b
--- /dev/null
+++ b/dev-python/pygobject/files/digest-pygobject-2.14.0-r1
@@ -0,0 +1,3 @@
+MD5 de781a21f483c941a73009a9f68f150e pygobject-2.14.0.tar.bz2 360630
+RMD160 71702329535680a813a36e05823d1968cb453b25 pygobject-2.14.0.tar.bz2 360630
+SHA256 3a5919703f71c2d7059d02f03dc6566cbe86c6efb09a16730b7cdb4b0fbef9e8 pygobject-2.14.0.tar.bz2 360630
diff --git a/dev-python/pygobject/files/pygobject-2.14.0-libffi-magic.patch b/dev-python/pygobject/files/pygobject-2.14.0-libffi-magic.patch
new file mode 100644
index 000000000000..9c5554739eac
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.14.0-libffi-magic.patch
@@ -0,0 +1,40 @@
+--- pygobject-2.14.0/configure.ac 2007/11/12 00:09:09 1.1
++++ pygobject-2.14.0/configure.ac 2007/11/12 00:22:35
+@@ -129,10 +129,33 @@ AC_SUBST([pygobject_CODEGEN_DEFINES])
+
+ dnl libffi
+ AC_MSG_CHECKING(for ffi.h)
+-AC_TRY_CPP([#include <ffi.h>], pygobject_ffi_h=yes, pygobject_ffi_h=no)
+-if test $pygobject_ffi_h = yes; then
+- AC_DEFINE(HAVE_FFI_H,1,[Have ffi.h include file])
+- FFI_LIBS="-lffi"
++AC_ARG_WITH(libffi,
++ AC_HELP_STRING([--without-libffi], [Disable libffi support]),
++ with_libffi=$withval,
++ with_libffi=auto)
++if test x"$with_libffi" = xno ; then
++ pygobject_ffi_h=disabled
++else
++ AC_TRY_CPP([#include <ffi.h>], pygobject_ffi_h=yes, pygobject_ffi_h=no)
++ if test $pygobject_ffi_h = yes; then
++ AC_DEFINE(HAVE_FFI_H,1,[Have ffi.h include file])
++ save_LIBS=$LIBS
++ if test x"$with_libffi" = xyes || test x"$with_libffi" = xauto; then
++ other_LIBS=
++ else
++ other_LIBS=$with_libffi
++ fi
++ AC_SEARCH_LIBS(ffi_call,ffi,,AC_MSG_ERROR([libffi not found]),$other_LIBS)
++ if test x$"ac_cv_search_ffi_call" = x"none required" ; then
++ FFI_LIBS=$other_LIBS
++ else
++ FFI_LIBS="$ac_cv_search_ffi_call $other_LIBS"
++ fi
++ LIBS=$save_LIBS
++ fi
++fi
++if test x"$with_libffi" = xyes && test x"$pygobject_ffi_h" != xyes ; then
++ AC_MSG_ERROR([libffi requested, but ffi.h not found])
+ fi
+ AC_MSG_RESULT([$pygobject_ffi_h])
+ AM_CONDITIONAL(HAVE_LIBFFI, test "$pygobject_ffi_h" = "yes")
diff --git a/dev-python/pygobject/pygobject-2.14.0-r1.ebuild b/dev-python/pygobject/pygobject-2.14.0-r1.ebuild
new file mode 100644
index 000000000000..65741aa645f0
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.14.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.0-r1.ebuild,v 1.1 2007/12/27 18:04:50 eva Exp $
+
+WANT_AUTOMAKE=1.8
+inherit gnome2 python autotools
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# glib higher dep than in configure.in comes from a runtime version check and ensures that
+# timeout_add_seconds is available for any packages that depend on pygobject and use it
+# python high dep for a fixed python-config, as aclocal.m4/configure in the tarball requires it to function properly
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.13.5
+ !<dev-python/pygtk-2.9"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # activate libffi when bug #199850 is solved
+ G2CONF="${G2CONF} $(use_enable doc docs) --without-libffi"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
+ # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
+ # patches (for tmpfs amongst other things). Upstreams hit by this should
+ # move to newer automake versions ideally.
+ # eautomake
+
+ # fix bug #198875 and bug #194632
+ epatch "${FILESDIR}/${P}-libffi-magic.patch"
+
+ # uncomment above eautomake when eautoreconf isn't needed anymore
+ cp aclocal.m4 old.m4
+ AT_M4DIR="." eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}