summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-29 16:51:14 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-29 16:51:14 +0000
commit3e6f8dbb260eeafb16aa42a6336185661d36d198 (patch)
tree65148c2f1970a4143386c0880bc931247d3c2302 /dev-python
parentStable for HPPA (bug #405965). (diff)
downloadgentoo-2-3e6f8dbb260eeafb16aa42a6336185661d36d198.tar.gz
gentoo-2-3e6f8dbb260eeafb16aa42a6336185661d36d198.tar.bz2
gentoo-2-3e6f8dbb260eeafb16aa42a6336185661d36d198.zip
Fix test failure on systems with long values in PORTAGE_TMPDIR. Bug 405985. Thanks to Ian Delaney for reporting here and upstream.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-1.0.0.ebuild6
-rw-r--r--dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch27
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 2d7b14d5c678..d18b0858e982 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.87 2012/02/27 04:43:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.88 2012/02/29 16:51:14 floppym Exp $
+
+ 29 Feb 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/dbus-python-1.0.0-test-socket-tmpdir.patch, dbus-python-1.0.0.ebuild:
+ Fix test failure on systems with long values in PORTAGE_TMPDIR. Bug 405985.
+ Thanks to Ian Delaney for reporting here and upstream.
27 Feb 2012; Jeroen Roovers <jer@gentoo.org> dbus-python-1.0.0.ebuild:
Stable for HPPA (bug #403843).
diff --git a/dev-python/dbus-python/dbus-python-1.0.0.ebuild b/dev-python/dbus-python/dbus-python-1.0.0.ebuild
index 94f20ebd83ba..2e2817bd293a 100644
--- a/dev-python/dbus-python/dbus-python-1.0.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.0.0.ebuild,v 1.8 2012/02/27 04:43:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.0.0.ebuild,v 1.9 2012/02/29 16:51:14 floppym Exp $
EAPI=4
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython 2.7-pypy-*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-inherit python
+inherit eutils python
DESCRIPTION="Python bindings for the D-Bus messagebus"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
@@ -34,6 +34,8 @@ src_prepare() {
# Fix tests with Python 3.1.
sed -e 's/if sys.version_info\[:2\] >= (2, 7):/if sys.version_info[:2] == (2, 7) or sys.version_info[:2] >= (3, 2):/' -i test/test-standalone.py || die "sed failed"
+ epatch "${FILESDIR}/${P}-test-socket-tmpdir.patch"
+
python_clean_py-compile_files
python_src_prepare
}
diff --git a/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch b/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch
new file mode 100644
index 000000000000..a1ab427cdf32
--- /dev/null
+++ b/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch
@@ -0,0 +1,27 @@
+From c53788657c0cfbd038325e690e7097e31f5e8430 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <simon.mcvittie@collabora.co.uk>
+Date: Wed, 29 Feb 2012 13:35:24 +0000
+Subject: Put sockets for the regression tests in /tmp, not ${builddir}
+
+Some automated build systems (naming no Portage) have really long build
+directories, which can cause dbus-python to hit the length limit for Unix
+sockets' names.
+
+Bug: https://bugs.freedesktop.org/show_bug.cgi?id=46747
+Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
+---
+diff --git a/test/tmp-session-bus.conf.in b/test/tmp-session-bus.conf.in
+index 9d172ff..3a2c756 100644
+--- a/test/tmp-session-bus.conf.in
++++ b/test/tmp-session-bus.conf.in
+@@ -4,7 +4,7 @@
+ <busconfig>
+ <!-- Our well-known bus type, don't change this -->
+ <type>session</type>
+- <listen>unix:tmpdir=@abs_top_builddir@/test</listen>
++ <listen>unix:tmpdir=/tmp</listen>
+
+ <servicedir>@abs_top_builddir@/test</servicedir>
+
+--
+cgit v0.9.0.2-2-gbebe