summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-11-23 01:19:57 +0000
committerMike Gilbert <floppym@gentoo.org>2012-11-23 01:19:57 +0000
commit3aed944354f27dd2c01c5ee0078977df6028226e (patch)
treeb0c41fc0b2b809de0ed8bff7fe71c0acc2217f81 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-3aed944354f27dd2c01c5ee0078977df6028226e.tar.gz
gentoo-2-3aed944354f27dd2c01c5ee0078977df6028226e.tar.bz2
gentoo-2-3aed944354f27dd2c01c5ee0078977df6028226e.zip
Update dependency on dev-python/py and add a safety check. Thanks to Arfrever for pointing out the problem.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/pytest-2.3.2-r1.ebuild10
-rw-r--r--dev-python/pytest/pytest-2.3.2.ebuild47
-rw-r--r--dev-python/pytest/pytest-2.3.3.ebuild10
4 files changed, 18 insertions, 56 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 0e25306f23a2..970a0f3dd15e 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.40 2012/11/11 11:05:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.41 2012/11/23 01:19:57 floppym Exp $
+
+ 23 Nov 2012; Mike Gilbert <floppym@gentoo.org> -pytest-2.3.2.ebuild,
+ pytest-2.3.2-r1.ebuild, pytest-2.3.3.ebuild:
+ Update dependency on dev-python/py and add a safety check. Thanks to Arfrever
+ for pointing out the problem.
*pytest-2.3.3 (11 Nov 2012)
diff --git a/dev-python/pytest/pytest-2.3.2-r1.ebuild b/dev-python/pytest/pytest-2.3.2-r1.ebuild
index 65a9f8a3d106..b4ce1ec5522b 100644
--- a/dev-python/pytest/pytest-2.3.2-r1.ebuild
+++ b/dev-python/pytest/pytest-2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2-r1.ebuild,v 1.1 2012/11/06 09:26:13 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2-r1.ebuild,v 1.2 2012/11/23 01:19:57 floppym Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -16,7 +16,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc"
-RDEPEND=">=dev-python/py-1.4.7"
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.11"
+RDEPEND=">=dev-python/py-${PY_VER}"
DEPEND="${RDEPEND}
app-arch/unzip
dev-python/setuptools"
@@ -25,10 +27,10 @@ DOCS="CHANGELOG README.txt"
PYTHON_MODNAME="pytest.py _pytest"
src_prepare() {
- distutils_src_prepare
-
# Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+ distutils_src_prepare
}
src_compile() {
diff --git a/dev-python/pytest/pytest-2.3.2.ebuild b/dev-python/pytest/pytest-2.3.2.ebuild
deleted file mode 100644
index 63766768f3ea..000000000000
--- a/dev-python/pytest/pytest-2.3.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2.ebuild,v 1.1 2012/10/30 08:05:44 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=dev-python/py-1.4.7"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools"
-
-DOCS="CHANGELOG README.txt"
-PYTHON_MODNAME="pytest.py _pytest"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
-
- # Bug 380275: Test suite pre-compiles modules
- python_clean_installation_image -q
-}
diff --git a/dev-python/pytest/pytest-2.3.3.ebuild b/dev-python/pytest/pytest-2.3.3.ebuild
index c2a73415c061..9180e6978cdc 100644
--- a/dev-python/pytest/pytest-2.3.3.ebuild
+++ b/dev-python/pytest/pytest-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.3.ebuild,v 1.1 2012/11/11 11:05:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.3.ebuild,v 1.2 2012/11/23 01:19:57 floppym Exp $
EAPI="4"
SUPPORT_PYTHON_ABIS="1"
@@ -16,7 +16,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc"
-RDEPEND=">=dev-python/py-1.4.7"
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.12"
+RDEPEND=">=dev-python/py-${PY_VER}"
DEPEND="${RDEPEND}
app-arch/unzip
dev-python/setuptools"
@@ -25,10 +27,10 @@ DOCS="CHANGELOG README.txt"
PYTHON_MODNAME="pytest.py _pytest"
src_prepare() {
- distutils_src_prepare
-
# Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+ distutils_src_prepare
}
src_compile() {