summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-31 19:59:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-31 19:59:11 +0000
commit353f440fdfb8585b8b2e4e32f296b19c0145dd29 (patch)
treed74f0a0ad611865383a30c9a74e9abfe7f23da3b /dev-python
parentIgnore tests failures with Jython. Patch by Arfrever. (diff)
downloadgentoo-2-353f440fdfb8585b8b2e4e32f296b19c0145dd29.tar.gz
gentoo-2-353f440fdfb8585b8b2e4e32f296b19c0145dd29.tar.bz2
gentoo-2-353f440fdfb8585b8b2e4e32f296b19c0145dd29.zip
Fix installation of eyeD3 script. Patch by Arfrever.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/eyeD3/ChangeLog7
-rw-r--r--dev-python/eyeD3/eyeD3-0.6.17.ebuild13
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-python/eyeD3/ChangeLog b/dev-python/eyeD3/ChangeLog
index 4d0e1416ae44..c93c338f69c7 100644
--- a/dev-python/eyeD3/ChangeLog
+++ b/dev-python/eyeD3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/eyeD3
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.44 2010/11/01 00:28:13 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/ChangeLog,v 1.45 2011/10/31 19:59:11 hwoarang Exp $
+
+ 31 Oct 2011; Markos Chandras <hwoarang@gentoo.org> eyeD3-0.6.17.ebuild:
+ Fix installation of eyeD3 script. Patch by Arfrever.
01 Nov 2010; Michael Weber <xmw@gentoo.org> eyeD3-0.6.17.ebuild:
Added ~arm keyword
diff --git a/dev-python/eyeD3/eyeD3-0.6.17.ebuild b/dev-python/eyeD3/eyeD3-0.6.17.ebuild
index d778dafb9db0..745f7a3aaab6 100644
--- a/dev-python/eyeD3/eyeD3-0.6.17.ebuild
+++ b/dev-python/eyeD3/eyeD3-0.6.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.6.17.ebuild,v 1.14 2010/11/01 00:28:13 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eyeD3/eyeD3-0.6.17.ebuild,v 1.15 2011/10/31 19:59:11 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -30,6 +30,13 @@ src_configure() {
src_install() {
dohtml *.html && rm -f *.html
distutils_src_install
- dobin bin/eyeD3 || die "dobin failed"
+
+ install_script() {
+ mkdir -p "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ cp bin/eyeD3 "${T}/images/${PYTHON_ABI}${EPREFIX}/usr/bin"
+ }
+ python_execute_function -q install_script
+ python_merge_intermediate_installation_images "${T}/images"
+
doman doc/*.1
}