summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-03 17:12:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-03 17:12:05 +0000
commit336ac5ac45fa1ed538232fcabc80755327917ee5 (patch)
treeaa3c81d72ed263c824bc06c9ab43d5029f14c29e /dev-python
parentAdd app-leechcraft/lcpackgen-1.2, thanks to 0xd34df00d. (diff)
downloadgentoo-2-336ac5ac45fa1ed538232fcabc80755327917ee5.tar.gz
gentoo-2-336ac5ac45fa1ed538232fcabc80755327917ee5.tar.bz2
gentoo-2-336ac5ac45fa1ed538232fcabc80755327917ee5.zip
Added missing dev-python/markdown dependency. Added tests, set them to not build in parallel to keep output clean; there is no need for that speedup for this small package.
(Portage version: 2.1.12.10/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markups/ChangeLog7
-rw-r--r--dev-python/markups/markups-0.2.4.ebuild16
2 files changed, 21 insertions, 2 deletions
diff --git a/dev-python/markups/ChangeLog b/dev-python/markups/ChangeLog
index 7eb5bfc76dc3..60da393ed3e0 100644
--- a/dev-python/markups/ChangeLog
+++ b/dev-python/markups/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/markups
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/markups/ChangeLog,v 1.2 2013/07/03 15:49:56 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/markups/ChangeLog,v 1.3 2013/07/03 17:12:05 tomwij Exp $
+
+ 03 Jul 2013; Tom Wijsman <TomWij@gentoo.org> markups-0.2.4.ebuild:
+ Added missing dev-python/markdown dependency. Added tests, set them to not
+ build in parallel to keep output clean; there is no need for that speedup for
+ this small package.
03 Jul 2013; Tom Wijsman <TomWij@gentoo.org> markups-0.2.4.ebuild:
Added and tested Python 3.3 compatibility, fixes bug #475478 reported by
diff --git a/dev-python/markups/markups-0.2.4.ebuild b/dev-python/markups/markups-0.2.4.ebuild
index a5eb1a6642ca..9747306896e6 100644
--- a/dev-python/markups/markups-0.2.4.ebuild
+++ b/dev-python/markups/markups-0.2.4.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/markups/markups-0.2.4.ebuild,v 1.2 2013/07/03 15:49:56 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/markups/markups-0.2.4.ebuild,v 1.3 2013/07/03 17:12:05 tomwij Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+DISTUTILS_NO_PARALLEL_BUILD="true"
+
inherit distutils-r1
MY_PN="Markups"
@@ -20,3 +22,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}"/${MY_P}
+
+DEPEND="dev-python/markdown"
+
+python_test() {
+ pushd tests > /dev/null
+ for test in test_*.py ; do
+ local testName="$(echo ${test} | sed 's/test_\(.*\).py/\1/g')"
+ einfo "Running test '${testName}' with '${EPYTHON}'."
+ ${EPYTHON} ${test} || die "Test '${testName}' with '${EPYTHON}' failed."
+ done
+ popd tests > /dev/null
+} \ No newline at end of file