summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-01-31 08:36:28 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-01-31 08:36:28 +0000
commit3325633a6ad43bd666b4162ad31dcd04661d19d9 (patch)
treead4acc9fae6361f9f276316ce11a02b5d5bbecdc /dev-python
parentfix KEYWORDS (diff)
downloadgentoo-2-3325633a6ad43bd666b4162ad31dcd04661d19d9.tar.gz
gentoo-2-3325633a6ad43bd666b4162ad31dcd04661d19d9.tar.bz2
gentoo-2-3325633a6ad43bd666b4162ad31dcd04661d19d9.zip
bumped to latest full release and cleaned up rc and beta ebuilds
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numpy/ChangeLog11
-rw-r--r--dev-python/numpy/files/digest-numpy-1.0.13
-rw-r--r--dev-python/numpy/files/digest-numpy-1.0_beta23
-rw-r--r--dev-python/numpy/files/digest-numpy-1.0_rc13
-rw-r--r--dev-python/numpy/numpy-1.0.1.ebuild (renamed from dev-python/numpy/numpy-1.0_rc1.ebuild)60
-rw-r--r--dev-python/numpy/numpy-1.0_beta2.ebuild57
6 files changed, 64 insertions, 73 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 72840dc9b85b..1a81736725b4 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/numpy
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.16 2006/09/26 07:52:55 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.17 2007/01/31 08:36:28 nerdboy Exp $
+
+*numpy-1.0.1 (31 Jan 2007)
+
+ 31 Jan 2007; Steve Arnold <nerdboy@gentoo.org> -numpy-1.0_beta2.ebuild,
+ -numpy-1.0_rc1.ebuild, +numpy-1.0.1.ebuild:
+ Bumped to latest full release and cleaned up rc and beta ebuilds (bug
+ 154275).
26 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; numpy-0.9.8.ebuild:
Stable on ppc.
diff --git a/dev-python/numpy/files/digest-numpy-1.0.1 b/dev-python/numpy/files/digest-numpy-1.0.1
new file mode 100644
index 000000000000..6bfc0c7d6798
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-1.0.1
@@ -0,0 +1,3 @@
+MD5 13a29244cbe03e0d45e56d8d90ecb55d numpy-1.0.1.tar.gz 1249684
+RMD160 f3a0c55aa5add8c93f91eee1bb05ff555c0f2485 numpy-1.0.1.tar.gz 1249684
+SHA256 c90d6f0ced132ef5bcd0b2791e0697bef6d92de45c2c591ea472d9f795757067 numpy-1.0.1.tar.gz 1249684
diff --git a/dev-python/numpy/files/digest-numpy-1.0_beta2 b/dev-python/numpy/files/digest-numpy-1.0_beta2
deleted file mode 100644
index 9643ac5b3567..000000000000
--- a/dev-python/numpy/files/digest-numpy-1.0_beta2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6aa929f8156b3fa2fc230a10ccef3353 numpy-1.0b2.tar.gz 1094555
-RMD160 1d0e90d87af7711ff7d7bea3e4270a41738d7dd4 numpy-1.0b2.tar.gz 1094555
-SHA256 8f7ee8b75349102170169c1ca6c652341708d9137a35196d6505dd47ea608f49 numpy-1.0b2.tar.gz 1094555
diff --git a/dev-python/numpy/files/digest-numpy-1.0_rc1 b/dev-python/numpy/files/digest-numpy-1.0_rc1
deleted file mode 100644
index cfd1544248e5..000000000000
--- a/dev-python/numpy/files/digest-numpy-1.0_rc1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b8cd486ee334520047f9a35454dad94a numpy-1.0rc1.tar.gz 1120453
-RMD160 2a08da4e7f9ea9c5ff8f43d3af63bd2af1218704 numpy-1.0rc1.tar.gz 1120453
-SHA256 af994dacc3e58beb51876b6d465fe5ca7435d945475ce382388453070102bb5c numpy-1.0rc1.tar.gz 1120453
diff --git a/dev-python/numpy/numpy-1.0_rc1.ebuild b/dev-python/numpy/numpy-1.0.1.ebuild
index b91c92ac92b5..b230cfb2ba2a 100644
--- a/dev-python/numpy/numpy-1.0_rc1.ebuild
+++ b/dev-python/numpy/numpy-1.0.1.ebuild
@@ -1,55 +1,99 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0_rc1.ebuild,v 1.3 2006/09/24 01:03:17 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0.1.ebuild,v 1.1 2007/01/31 08:36:28 nerdboy Exp $
-inherit distutils
+inherit distutils fortran
MY_P=${P/_beta/b}
MY_P=${MY_P/_}
DESCRIPTION="Multi-dimensional array object and processing for Python."
SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
HOMEPAGE="http://numeric.scipy.org/"
+
# numpy provides the latest version of dev-python/f2py
DEPEND=">=dev-lang/python-2.3
!dev-python/f2py
lapack? ( virtual/blas
virtual/lapack )"
+
IUSE="lapack"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
LICENSE="BSD"
RESTRICT="test"
S="${WORKDIR}/${MY_P}"
+FORTRAN="g77 gfortran"
+
src_unpack() {
unpack ${A}
cd "${S}"
# sed to patch ATLAS libraries names (gentoo specific)
sed -i \
-e "s:f77blas:blas:g" \
+ -e "s:ptblas:blas:g" \
+ -e "s:ptcblas:cblas:g" \
+ -e "s:lapack_atlas:lapack:g" \
numpy/distutils/system_info.py
if use lapack; then
echo "[atlas]" > site.cfg
echo "include_dirs = /usr/include/atlas" >> site.cfg
echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
- echo -n "library_dirs = /usr/$(get_libdir)/lapack:" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack::/usr/$(get_libdir):" \
+ >> site.cfg
if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
else
echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
fi
- else
- export ATLAS=None
fi
}
src_compile() {
+ # Map compilers to what numpy calls them (same as scipy)
+ local NUMPY_FC
+ case "${FORTRANC}" in
+ gfortran)
+ NUMPY_FC="gnu95"
+ ;;
+ g77)
+ NUMPY_FC="gnu"
+ ;;
+ g95)
+ NUMPY_FC="g95"
+ ;;
+ ifc|ifort)
+ if use ia64; then
+ NUMPY_FC="intele"
+ else
+ NUMPY_FC="intel"
+ fi
+ ;;
+ *)
+ local msg="Invalid Fortran compiler \'${FORTRANC}\'"
+ eerror "${msg}"
+ die "${msg}"
+ ;;
+ esac
+
+ if !(use lapack); then
+ rm -f site.cfg
+ export BLAS=None
+ export LAPACK=None
+ export ATLAS=None
+ fi
+
# http://projects.scipy.org/scipy/numpy/ticket/182
# Can't set LDFLAGS
unset LDFLAGS
+ export F77LFLAGS="${F77LFLAGS} -fPIC"
- distutils_src_compile
+ distutils_src_compile \
+ config_fc \
+ --fcompiler=${NUMPY_FC} \
+ --opt="${CFLAGS}" \
+ || die "compilation failed"
}
src_install() {
diff --git a/dev-python/numpy/numpy-1.0_beta2.ebuild b/dev-python/numpy/numpy-1.0_beta2.ebuild
deleted file mode 100644
index 975f92081d4a..000000000000
--- a/dev-python/numpy/numpy-1.0_beta2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0_beta2.ebuild,v 1.4 2006/09/24 01:03:17 dberkholz Exp $
-
-inherit distutils
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Multi-dimensional array object and processing for Python."
-SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
-HOMEPAGE="http://numeric.scipy.org/"
-# numpy provides the latest version of dev-python/f2py
-DEPEND=">=dev-lang/python-2.3
- !dev-python/f2py
- lapack? ( virtual/blas
- virtual/lapack )"
-IUSE="lapack"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="BSD"
-RESTRICT="test"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # sed to patch ATLAS libraries names (gentoo specific)
- sed -i \
- -e "s:f77blas:blas:g" \
- numpy/distutils/system_info.py
-
- if use lapack; then
- echo "[atlas]" > site.cfg
- echo "include_dirs = /usr/include/atlas" >> site.cfg
- echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
- echo -n "library_dirs = /usr/$(get_libdir)/lapack:" >> site.cfg
- if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
- echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
- else
- echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
- fi
- else
- export ATLAS=None
- fi
-}
-
-src_compile() {
- # http://projects.scipy.org/scipy/numpy/ticket/182
- # Can't set LDFLAGS
- unset LDFLAGS
-
- distutils_src_compile
-}
-
-src_install() {
- distutils_src_install
- dodoc numpy/doc/*
-}