summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 16:05:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-04 16:05:11 +0000
commit31ba55262e9ce0b2efe1a6d6dae07e3759236a85 (patch)
tree669c745e1dc7eee27c5f810c74553b01a49e721d /dev-python
parentRestore 2.4.2, thanks to fauli for telling me. Remove the betas as intended. (diff)
downloadgentoo-2-31ba55262e9ce0b2efe1a6d6dae07e3759236a85.tar.gz
gentoo-2-31ba55262e9ce0b2efe1a6d6dae07e3759236a85.tar.bz2
gentoo-2-31ba55262e9ce0b2efe1a6d6dae07e3759236a85.zip
Fix building with glibc-2.10 and gcc-4.4 (bug #274076).
(Portage version: 13775-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyid3lib/ChangeLog9
-rw-r--r--dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch20
-rw-r--r--dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild11
-rw-r--r--dev-python/pyid3lib/pyid3lib-0.5.1.ebuild20
4 files changed, 34 insertions, 26 deletions
diff --git a/dev-python/pyid3lib/ChangeLog b/dev-python/pyid3lib/ChangeLog
index f517f06f4d0c..80c1413c8aee 100644
--- a/dev-python/pyid3lib/ChangeLog
+++ b/dev-python/pyid3lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyid3lib
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyid3lib/ChangeLog,v 1.18 2008/01/26 06:53:38 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyid3lib/ChangeLog,v 1.19 2009/07/04 16:05:10 arfrever Exp $
+
+ 04 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pyid3lib-0.5.1.ebuild, pyid3lib-0.5.1-r1.ebuild,
+ +files/pyid3lib-0.5.1-gcc-4.4.patch:
+ Fix building with glibc-2.10 and gcc-4.4 (bug #274076).
26 Jan 2008; Samuli Suominen <drac@gentoo.org> pyid3lib-0.5.1-r1.ebuild:
amd64 stable wrt #207255
diff --git a/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch b/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch
new file mode 100644
index 000000000000..04df9e0a6c98
--- /dev/null
+++ b/dev-python/pyid3lib/files/pyid3lib-0.5.1-gcc-4.4.patch
@@ -0,0 +1,20 @@
+--- pyid3lib.cc
++++ pyid3lib.cc
+@@ -920,7 +920,7 @@ enum frame_type
+
+ typedef struct
+ {
+- char* name;
++ const char* name;
+ ID3_FrameID fid;
+ frame_type type;
+ } magic_attribute;
+@@ -1030,7 +1030,7 @@ static PyObject* id3_getattr( ID3Object* self, char* attrname )
+ {
+ ID3_Frame* frame;
+ const char* str;
+- char* slash;
++ const char* slash;
+ ID3_Field* fld;
+ int i;
+
diff --git a/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
index 0ef604c82b0f..83dbc00ec928 100644
--- a/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
+++ b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild,v 1.7 2008/01/26 06:53:38 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild,v 1.8 2009/07/04 16:05:10 arfrever Exp $
+
+EAPI="2"
inherit distutils eutils
@@ -13,9 +15,10 @@ LICENSE="LGPL-2.1"
KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
DEPEND="virtual/python
media-libs/id3lib"
+RDEPEND="${DEPEND}"
-src_unpack() {
- distutils_src_unpack
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc-4.4.patch"
epatch "${FILESDIR}/${P}-py25.patch"
}
diff --git a/dev-python/pyid3lib/pyid3lib-0.5.1.ebuild b/dev-python/pyid3lib/pyid3lib-0.5.1.ebuild
deleted file mode 100644
index 8a92a4cd4b6b..000000000000
--- a/dev-python/pyid3lib/pyid3lib-0.5.1.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyid3lib/pyid3lib-0.5.1.ebuild,v 1.13 2007/07/11 06:19:47 mr_bones_ Exp $
-
-inherit distutils
-
-DESCRIPTION="Module for manipulating ID3 tags in Python"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-HOMEPAGE="http://pyid3lib.sourceforge.net/"
-IUSE=""
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-DEPEND="virtual/python
- media-libs/id3lib"
-
-src_install() {
- distutils_src_install
- dohtml doc.html
-}