summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-18 17:32:34 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-18 17:32:34 +0000
commit2ebbad61a257ee5ee1a404f4d4ec223f1a957d91 (patch)
tree6e558c0a0b961b23ae9eccf13751e581bdf590d8 /dev-python
parentremove leechraft-muziczombie (invalid name) (diff)
downloadgentoo-2-2ebbad61a257ee5ee1a404f4d4ec223f1a957d91.tar.gz
gentoo-2-2ebbad61a257ee5ee1a404f4d4ec223f1a957d91.tar.bz2
gentoo-2-2ebbad61a257ee5ee1a404f4d4ec223f1a957d91.zip
Generate API docs only when using python-2.7 since epydoc is incompatible with python3 (bug #447642, thanks to Juergen Rose).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild31
2 files changed, 27 insertions, 11 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 75174d040d19..fa3f1f97663b 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.108 2012/12/10 09:18:48 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.109 2012/12/18 17:32:34 tetromino Exp $
+
+ 18 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ dbus-python-1.1.1-r1.ebuild:
+ Generate API docs only when using python-2.7 since epydoc is incompatible
+ with python3 (bug #447642, thanks to Juergen Rose).
*dbus-python-1.1.1-r1 (10 Dec 2012)
diff --git a/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild b/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
index ab305c79e608..f5e6f4153a53 100644
--- a/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild,v 1.1 2012/12/10 09:18:48 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.1-r1.ebuild,v 1.2 2012/12/18 17:32:34 tetromino Exp $
EAPI=5
@@ -16,27 +16,38 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+# API docs generated with epydoc, which is python2-only
+REQUIRED_USE="doc? ( || ( python_targets_python2_6 python_targets_python2_7 ) )"
RDEPEND=">=dev-libs/dbus-glib-0.100:=
>=sys-apps/dbus-1.6:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( =dev-python/epydoc-3* )
+ doc? (
+ dev-python/docutils[python_targets_python2_6?,python_targets_python2_7?]
+ =dev-python/epydoc-3*[python_targets_python2_6?,python_targets_python2_7?] )
test? ( dev-python/pygobject:3 )"
-# TODO: should be dev-python/pygobject:3[${PYTHON_USEDEP]
+# TODO: should be dev-python/pygobject:3[${PYTHON_USEDEP] when pygobject-3.4 is unmasked
src_prepare() {
python_copy_sources
}
src_configure() {
- python_foreach_impl run_in_build_dir econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-html-docs \
- $(use_enable doc api-docs) \
- PYTHON_LIBS="$(python-config --ldflags)"
- # configure assumes that ${PYTHON}-config executable exists :/
+ configuring() {
+ # epydoc is python2-only, bug #447642
+ local apidocs=--disable-api-docs
+ [[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-html-docs \
+ ${apidocs} \
+ PYTHON_LIBS="$(python-config --ldflags)"
+ # configure assumes that ${PYTHON}-config executable exists :/
+ }
+ python_foreach_impl run_in_build_dir configuring
}
src_compile() {
@@ -51,7 +62,7 @@ src_test() {
src_install() {
installing() {
default
- use doc && nonfatal dohtml -r api/*
+ [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
}
python_foreach_impl run_in_build_dir installing
prune_libtool_files --modules