summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDion Moult <moult@gentoo.org>2013-03-24 10:42:26 +0000
committerDion Moult <moult@gentoo.org>2013-03-24 10:42:26 +0000
commit2b64170333c68a10b85de36d8ce42e78b456df7e (patch)
tree12bf754abffc97e6e3467905787a0a6fbee8a627 /dev-python
parentVersion bump. EAPI bump. Migration to python-r1. (diff)
downloadgentoo-2-2b64170333c68a10b85de36d8ce42e78b456df7e.tar.gz
gentoo-2-2b64170333c68a10b85de36d8ce42e78b456df7e.tar.bz2
gentoo-2-2b64170333c68a10b85de36d8ce42e78b456df7e.zip
dev-python/pysqlite-2 removal (pending 17th January 2013), see #452122 for reference.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild57
-rw-r--r--dev-python/pysqlite/pysqlite-2.6.3.ebuild64
2 files changed, 0 insertions, 121 deletions
diff --git a/dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild b/dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild
deleted file mode 100644
index 65b99757ebc4..000000000000
--- a/dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild,v 1.2 2013/01/14 21:11:20 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="DB-API 2.0 interface for SQLite 3.x"
-HOMEPAGE="http://code.google.com/p/pysqlite/ http://pypi.python.org/pypi/pysqlite"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="pysqlite"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="examples"
-
-DEPEND=">=dev-db/sqlite-3.3.8:3[extensions]"
-RDEPEND=${DEPEND}
-
-python_prepare_all() {
- # Enable support for loadable sqlite extensions.
- sed -e "/define=SQLITE_OMIT_LOAD_EXTENSION/d" -i setup.cfg || die
-
- # Fix encoding.
- sed -e "/coding:/s:ISO-8859-1:utf-8:" \
- -i lib/{__init__.py,dbapi2.py} || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_test() {
- local script='
-import sys, pysqlite2.test, unittest
-r = unittest.TextTestRunner().run(pysqlite2.test.suite())
-sys.exit(0 if r.wasSuccessful() else 1)'
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "${script}" \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- rm -rf "${ED}usr/pysqlite2-doc"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r doc/includes/sqlite3/. || die
- fi
-}
diff --git a/dev-python/pysqlite/pysqlite-2.6.3.ebuild b/dev-python/pysqlite/pysqlite-2.6.3.ebuild
deleted file mode 100644
index 0e151a1d2413..000000000000
--- a/dev-python/pysqlite/pysqlite-2.6.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.6.3.ebuild,v 1.8 2012/02/24 01:09:05 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="DB-API 2.0 interface for SQLite 3.x"
-HOMEPAGE="http://code.google.com/p/pysqlite/ http://pypi.python.org/pypi/pysqlite"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="pysqlite"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="examples"
-
-DEPEND=">=dev-db/sqlite-3.3.8:3[extensions]"
-RDEPEND=${DEPEND}
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-PYTHON_MODNAME="pysqlite2"
-
-src_prepare() {
- distutils_src_prepare
-
- # Enable support for loadable sqlite extensions.
- sed -e "/define=SQLITE_OMIT_LOAD_EXTENSION/d" -i setup.cfg || die "sed setup.cfg failed"
-
- # Fix encoding.
- sed -e "s/\(coding: \)ISO-8859-1/\1utf-8/" -i lib/{__init__.py,dbapi2.py} || die "sed lib/{__init__.py,dbapi2.py} failed"
-
- # Workaround to make tests work without installing them.
- sed -e "s/pysqlite2.test/test/" -i lib/test/__init__.py || die "sed lib/test/__init__.py failed"
-}
-
-src_test() {
- cd lib
-
- testing() {
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "from test import test; import sys; sys.exit(test())"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- rm -rf "${ED}usr/pysqlite2-doc"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins doc/includes/sqlite3/* || die "Installation of examples failed"
- fi
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/pysqlite2/test"
- }
- python_execute_function -q delete_tests
-}