summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2010-04-22 06:50:43 +0000
committerBrian Harring <ferringb@gentoo.org>2010-04-22 06:50:43 +0000
commit2084b8ea637b9c06d33f6ff24d5c5e94af7c9968 (patch)
tree7f612af6259c7e66fe8b7da26a34ece5aad51cd1 /dev-python
parentclean out old versions (diff)
downloadgentoo-2-2084b8ea637b9c06d33f6ff24d5c5e94af7c9968.tar.gz
gentoo-2-2084b8ea637b9c06d33f6ff24d5c5e94af7c9968.tar.bz2
gentoo-2-2084b8ea637b9c06d33f6ff24d5c5e94af7c9968.zip
blar. still getting acclimated to the cvs workflow still... punt 0.3.6 since it's unneeded in addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.6.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.3.6.ebuild b/dev-python/snakeoil/snakeoil-0.3.6.ebuild
deleted file mode 100644
index 24180cda0b85..000000000000
--- a/dev-python/snakeoil/snakeoil-0.3.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.6.ebuild,v 1.1 2010/01/09 00:16:18 patrick Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Miscellaneous python utility code."
-HOMEPAGE="http://www.pkgcore.org/"
-SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
-
-DEPEND="!<sys-apps/pkgcore-0.4.7.8"
-RDEPEND=${DEPEND}
-
-DOCS="AUTHORS NEWS"
-
-pkg_setup() {
- validate_PYTHON_ABIS
-
- # A hack to install for all versions of Python in the system.
- # pkgcore needs it to support upgrading to a different Python slot.
- PYTHON_ABIS=""
- local python_interpreter
- for python_interpreter in /usr/bin/python{2.[4-9],3.[1-9]}; do
- if [[ -x "${python_interpreter}" ]]; then
- PYTHON_ABIS+=" ${python_interpreter#/usr/bin/python}"
- fi
- done
- export PYTHON_ABIS="${PYTHON_ABIS# }"
-}
-
-src_test() {
- testing() {
- local tempdir
- tempdir="${T}/tests/python-${PYTHON_ABI}"
- mkdir -p "${tempdir}" || die "tempdir creation failed"
- cp -r "${S}" "${tempdir}" || die "test copy failed"
- cd "${tempdir}/${P}"
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- python_execute_function testing
-}