summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-13 07:40:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-13 07:40:25 +0000
commit2008c237d729bea521e99e972ec53e79e817df20 (patch)
treea018bd32b8d78900034bd8c8ce2c4e6d4e166770 /dev-python
parentAdd setuptools dependency (bug #532150) (diff)
downloadgentoo-2-2008c237d729bea521e99e972ec53e79e817df20.tar.gz
gentoo-2-2008c237d729bea521e99e972ec53e79e817df20.tar.bz2
gentoo-2-2008c237d729bea521e99e972ec53e79e817df20.zip
offending test seded out wrt Bug #530388
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apipkg/ChangeLog5
-rw-r--r--dev-python/apipkg/apipkg-1.2-r1.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/apipkg/ChangeLog b/dev-python/apipkg/ChangeLog
index 4527a2f08266..afa87781391f 100644
--- a/dev-python/apipkg/ChangeLog
+++ b/dev-python/apipkg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/apipkg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/ChangeLog,v 1.8 2014/12/13 07:13:13 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/ChangeLog,v 1.9 2014/12/13 07:40:25 idella4 Exp $
+
+ 13 Dec 2014; Ian Delaney <idella4@gentoo.org> apipkg-1.2-r1.ebuild:
+ offending test seded out wrt Bug #530388
13 Dec 2014; Ian Delaney <idella4@gentoo.org> -apipkg-1.0.ebuild,
-apipkg-1.2.ebuild, apipkg-1.2-r1.ebuild:
diff --git a/dev-python/apipkg/apipkg-1.2-r1.ebuild b/dev-python/apipkg/apipkg-1.2-r1.ebuild
index 1588bdfc13ad..0a922a5fbd6b 100644
--- a/dev-python/apipkg/apipkg-1.2-r1.ebuild
+++ b/dev-python/apipkg/apipkg-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/apipkg-1.2-r1.ebuild,v 1.4 2014/12/13 07:13:13 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/apipkg-1.2-r1.ebuild,v 1.5 2014/12/13 07:40:25 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
@@ -20,8 +20,13 @@ RDEPEND=""
DEPEND="app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
+python_prepare_all() {
# https://bitbucket.org/hpk42/apipkg/issue/5/test-failure-with-python-34
+ sed -e 's:test_initpkg_not_transfers_not_existing_attrs:_&:' -i test_apipkg.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
# Bug 530388. The test requires patching to match py3.4; trivial.
py.test || die "Tests fail under ${EPYTHON}"
}