summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2009-02-10 15:35:46 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2009-02-10 15:35:46 +0000
commit1bde8df3fc6c4b7ceb38e655aff888821c38ab68 (patch)
tree17f00a1c2dd49153bc6ad0db18101aeb4164bbd7 /dev-python
parent~amd64 keyworded. Small cleanups. Added to netmon since smokeping relies on t... (diff)
downloadgentoo-2-1bde8df3fc6c4b7ceb38e655aff888821c38ab68.tar.gz
gentoo-2-1bde8df3fc6c4b7ceb38e655aff888821c38ab68.tar.bz2
gentoo-2-1bde8df3fc6c4b7ceb38e655aff888821c38ab68.zip
added patch to work with >= sqlite 3.6.4
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/axiom/ChangeLog6
-rw-r--r--dev-python/axiom/axiom-0.5.30.ebuild5
-rw-r--r--dev-python/axiom/files/axiom-0.5.30-sqlite3_3.6.4.patch36
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/axiom/ChangeLog b/dev-python/axiom/ChangeLog
index 3b46900ee666..b8c73f1c7595 100644
--- a/dev-python/axiom/ChangeLog
+++ b/dev-python/axiom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/axiom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.19 2009/02/10 11:03:08 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/ChangeLog,v 1.20 2009/02/10 15:35:46 lordvan Exp $
+
+ 10 Feb 2009; Thomas Raschbacher <lordvan@gentoo.org>
+ +files/axiom-0.5.30-sqlite3_3.6.4.patch, axiom-0.5.30.ebuild:
+ added patch for it to work with >= sqlite-3.6.4
*axiom-0.5.30 (10 Feb 2009)
diff --git a/dev-python/axiom/axiom-0.5.30.ebuild b/dev-python/axiom/axiom-0.5.30.ebuild
index e418885e8573..cc040db17688 100644
--- a/dev-python/axiom/axiom-0.5.30.ebuild
+++ b/dev-python/axiom/axiom-0.5.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/axiom-0.5.30.ebuild,v 1.1 2009/02/10 11:03:08 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/axiom/axiom-0.5.30.ebuild,v 1.2 2009/02/10 15:35:46 lordvan Exp $
inherit twisted distutils eutils
@@ -32,6 +32,9 @@ DOCS="NAME.txt"
src_unpack() {
distutils_src_unpack
epatch "${FILESDIR}/${P}-sqlite3.patch"
+ if has_version ">=dev-db/sqlite-3.6.4"; then
+ epatch "${FILESDIR}/${P}-sqlite3_3.6.4.patch"
+ fi
}
src_compile() {
diff --git a/dev-python/axiom/files/axiom-0.5.30-sqlite3_3.6.4.patch b/dev-python/axiom/files/axiom-0.5.30-sqlite3_3.6.4.patch
new file mode 100644
index 000000000000..cfa465ce656c
--- /dev/null
+++ b/dev-python/axiom/files/axiom-0.5.30-sqlite3_3.6.4.patch
@@ -0,0 +1,36 @@
+--- axiom/_schema.py (revision 17031)
++++ axiom/_schema.py (working copy)
+@@ -28,7 +28,7 @@
+ CREATE TABLE *DATABASE*.axiom_attributes (
+ type_id INTEGER,
+ row_offset INTEGER,
+- indexed BOOLEAN,
++ "indexed" BOOLEAN,
+ sqltype VARCHAR,
+ allow_none BOOLEAN,
+ pythontype VARCHAR,
+@@ -47,13 +47,13 @@
+ HAS_SCHEMA_FEATURE = ("SELECT COUNT(oid) FROM *DATABASE*.sqlite_master "
+ "WHERE type = ? AND name = ?")
+
+-IDENTIFYING_SCHEMA = ('SELECT indexed, sqltype, allow_none, attribute '
++IDENTIFYING_SCHEMA = ('SELECT "indexed", sqltype, allow_none, attribute '
+ 'FROM *DATABASE*.axiom_attributes WHERE type_id = ? '
+ 'ORDER BY row_offset')
+
+ ADD_SCHEMA_ATTRIBUTE = (
+ 'INSERT INTO *DATABASE*.axiom_attributes '
+- '(type_id, row_offset, indexed, sqltype, allow_none, attribute, docstring, pythontype) '
++ '(type_id, row_offset, "indexed", sqltype, allow_none, attribute, docstring, pythontype) '
+ 'VALUES (?, ?, ?, ?, ?, ?, ?, ?)')
+
+ ALL_TYPES = 'SELECT oid, module, typename, version FROM *DATABASE*.axiom_types'
+@@ -61,7 +61,7 @@
+ GET_GREATER_VERSIONS_OF_TYPE = ('SELECT version FROM *DATABASE*.axiom_types '
+ 'WHERE typename = ? AND version > ?')
+
+-SCHEMA_FOR_TYPE = ('SELECT indexed, pythontype, attribute, docstring '
++SCHEMA_FOR_TYPE = ('SELECT "indexed", pythontype, attribute, docstring '
+ 'FROM *DATABASE*.axiom_attributes '
+ 'WHERE type_id = ?')
+