summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-12-09 05:04:54 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-12-09 05:04:54 +0000
commit18cda05aaaba68333fa98c1683d17e5d1c7dc1fd (patch)
tree96581f70e11e60ee34051d2a57ac503ee8c1b3c0 /dev-python
parentSymlink /lib to the default ABI, not to a hardcoded default. (diff)
downloadgentoo-2-18cda05aaaba68333fa98c1683d17e5d1c7dc1fd.tar.gz
gentoo-2-18cda05aaaba68333fa98c1683d17e5d1c7dc1fd.tar.bz2
gentoo-2-18cda05aaaba68333fa98c1683d17e5d1c7dc1fd.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1.ebuild187
2 files changed, 193 insertions, 1 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index cefd6dd88129..5b112e366335 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.151 2011/12/09 03:29:30 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.152 2011/12/09 05:04:54 dirtyepic Exp $
+
+*wxpython-2.8.12.1 (09 Dec 2011)
+
+ 09 Dec 2011; Ryan Hill <dirtyepic@gentoo.org> +wxpython-2.8.12.1.ebuild:
+ Version bump.
09 Dec 2011; Ryan Hill <dirtyepic@gentoo.org> -wxpython-2.8.10.1.ebuild,
-files/wxpython-2.8-drop-editra.patch:
diff --git a/dev-python/wxpython/wxpython-2.8.12.1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
new file mode 100644
index 000000000000..e9505c3eadbc
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.1 2011/12/09 05:04:54 dirtyepic Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+WX_GTK_VER="2.8"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+
+MY_P="${P/wxpython-/wxPython-src-}"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2
+ doc? ( mirror://sourceforge/wxpython/wxPython-docs-${PV}.tar.bz2
+ mirror://sourceforge/wxpython/wxPython-newdocs-2.8.9.2.tar.bz2 )
+ examples? ( mirror://sourceforge/wxpython/wxPython-demo-${PV}.tar.bz2 )"
+
+LICENSE="wxWinLL-3"
+SLOT="2.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cairo doc examples opengl"
+
+RDEPEND="
+ >=x11-libs/wxGTK-${PV}:2.8[opengl?,tiff,X]
+ dev-libs/glib:2
+ dev-python/setuptools
+ media-libs/libpng:0
+ media-libs/tiff:0
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/pango[X]
+ cairo? ( >=dev-python/pycairo-1.8.4 )
+ opengl? ( dev-python/pyopengl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+S="${WORKDIR}/${MY_P}/wxPython"
+DOC_S="${WORKDIR}/wxPython-${PV}"
+
+src_prepare() {
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-2.8.9-wxversion-scripts.patch
+ # drop editra - we have it as a separate package now
+ epatch "${FILESDIR}"/${PN}-2.8.12-drop-editra.patch
+
+ if use doc; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-cache-writable.patch
+ fi
+
+ if use examples; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-demo.patch
+ fi
+
+ python_copy_sources
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ append-flags -fno-strict-aliasing
+
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+}
+
+src_compile() {
+ building() {
+ "$(PYTHON)" setup.py ${mypyconf} build
+ }
+ python_execute_function -s building
+}
+
+src_install() {
+ local docdir mypyconf
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+
+ installation() {
+ "$(PYTHON)" setup.py ${mypyconf} install --root="${D}" --install-purelib $(python_get_sitedir)
+ }
+ python_execute_function -s installation
+
+ # Collision protection.
+ for file in "${D}"/usr/bin/*; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+ rename_files() {
+ for file in "${D}$(python_get_sitedir)/"wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}" || return 1
+ done
+ }
+ python_execute_function -q rename_files
+
+ dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
+
+ insinto /usr/share/applications
+ doins "${S}"/distrib/{Py{AlaMode,Crust,Shell},XRCed}.desktop
+ insinto /usr/share/pixmaps
+ newins "${S}"/wx/py/PyCrust_32.png PyCrust.png
+ newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed.png
+
+ docdir=${D}usr/share/doc/${PF}
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}/docs
+ cp -R "${DOC_S}"/docs/* "${docdir}"/docs/
+ # For some reason newer API docs aren't available so use 2.8.9.2's
+ cp -R "${WORKDIR}"/wxPython-2.8.9.2/docs/* "${docdir}"/docs/
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/demo
+ cp -R "${DOC_S}"/demo/* "${docdir}"/demo
+ dodir /usr/share/doc/${PF}/samples
+ cp -R "${DOC_S}"/samples/* "${docdir}"/samples
+ [[ -e ${docdir}/samples/embedded/embedded ]] \
+ && rm -f "${docdir}"/samples/embedded/embedded
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+
+ python_mod_optimize wx-${SLOT}-gtk2-unicode wxversion.py
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers, see this site for instructions on using"
+ elog "2.6 or 2.8 with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ echo
+ if use doc; then
+ elog "To access the general wxWidgets documentation, run"
+ elog "/usr/share/doc/${PF}/docs/viewdocs.py"
+ elog
+ elog "wxPython documentation is available by pointing a browser"
+ elog "at /usr/share/doc/${PF}/docs/api/index.html"
+ fi
+ if use examples; then
+ elog
+ elog "The demo.py app which contains hundreds of demo modules"
+ elog "with documentation and source code has been installed at"
+ elog "/usr/share/doc/${PF}/demo/demo.py"
+ elog
+ elog "Many more example apps and modules can be found in"
+ elog "/usr/share/doc/${PF}/samples/"
+ echo
+ fi
+ elog "Editra is not packaged with wxpython in Gentoo."
+ elog "You can find it in the tree as app-editors/editra"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup wx-${SLOT}-gtk2-unicode wxversion.py
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+}