summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-20 10:54:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-20 10:54:02 +0000
commit16255acbaa23714911cd82cdb05e391ddbf14321 (patch)
tree182cb70abcb83937278a2917dc84023343f33c2c /dev-python
parentStable for x86, wrt bug #510208 (diff)
downloadgentoo-2-16255acbaa23714911cd82cdb05e391ddbf14321.tar.gz
gentoo-2-16255acbaa23714911cd82cdb05e391ddbf14321.tar.bz2
gentoo-2-16255acbaa23714911cd82cdb05e391ddbf14321.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.6.2.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 21bf8d77f7a9..fcda63e8ef4a 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.132 2014/07/21 17:11:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.133 2014/08/20 10:54:02 idella4 Exp $
+
+*simplejson-3.6.2 (20 Aug 2014)
+
+ 20 Aug 2014; Ian Delaney <idella4@gentoo.org> +simplejson-3.6.2.ebuild:
+ bump
*simplejson-3.6.0 (21 Jul 2014)
diff --git a/dev-python/simplejson/simplejson-3.6.2.ebuild b/dev-python/simplejson/simplejson-3.6.2.ebuild
new file mode 100644
index 000000000000..2f40ed268a0b
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.2.ebuild,v 1.1 2014/08/20 10:54:02 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}