summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-27 22:47:19 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-27 22:47:19 +0000
commit125d53f0086ebfef2ca2733d5296e4f62135ed90 (patch)
treecf9700452070d3c1dc4daf91e88a8ff7a8aebf0f /dev-python
parentStable on hppa. (diff)
downloadgentoo-2-125d53f0086ebfef2ca2733d5296e4f62135ed90.tar.gz
gentoo-2-125d53f0086ebfef2ca2733d5296e4f62135ed90.tar.bz2
gentoo-2-125d53f0086ebfef2ca2733d5296e4f62135ed90.zip
Re-added version 2.2.1 since upstream still maintains that branch it is needed by Turbogears. Added doc USE-flags for tutorial installation.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cherrypy/ChangeLog7
-rw-r--r--dev-python/cherrypy/cherrypy-2.2.1.ebuild46
-rw-r--r--dev-python/cherrypy/cherrypy-3.0.0.ebuild25
-rw-r--r--dev-python/cherrypy/cherrypy-3.0.1.ebuild31
-rw-r--r--dev-python/cherrypy/files/digest-cherrypy-2.2.13
-rw-r--r--dev-python/cherrypy/files/digest-cherrypy-3.0.03
6 files changed, 81 insertions, 34 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index b986311ef3d3..2eed41b188c7 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.18 2007/02/27 21:10:21 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.19 2007/02/27 22:47:19 dev-zero Exp $
+
+ 27 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> +cherrypy-2.2.1.ebuild,
+ -cherrypy-3.0.0.ebuild, cherrypy-3.0.1.ebuild:
+ Re-added version 2.2.1 since upstream still maintains that branch and it is
+ needed by Turbogears. Added doc USE-flags for tutorial installation.
*cherrypy-3.0.1 (27 Feb 2007)
diff --git a/dev-python/cherrypy/cherrypy-2.2.1.ebuild b/dev-python/cherrypy/cherrypy-2.2.1.ebuild
new file mode 100644
index 000000000000..335d569e0d45
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-2.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.2.1.ebuild,v 1.3 2007/02/27 22:47:19 dev-zero Exp $
+
+inherit distutils
+
+MY_P=CherryPy-${PV}
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
+SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cherrypy.org/"
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="BSD"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/raw_input/d' \
+ cherrypy/test/test.py || die "sed failed"
+ sed -i \
+ -e 's/"cherrypy.tutorial",//' \
+ -e "/('cherrypy\/tutorial',/, /),/d" \
+ setup.py || die "sed failed"
+
+}
+
+src_install() {
+ distutils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r cherrypy/tutorial
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" cherrypy/test/test.py || die "test failed"
+}
diff --git a/dev-python/cherrypy/cherrypy-3.0.0.ebuild b/dev-python/cherrypy/cherrypy-3.0.0.ebuild
deleted file mode 100644
index d84af5a14abb..000000000000
--- a/dev-python/cherrypy/cherrypy-3.0.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.0.ebuild,v 1.1 2006/12/27 02:20:22 dev-zero Exp $
-
-inherit distutils
-
-MY_P=CherryPy-${PV}
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
-SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
-HOMEPAGE="http://www.cherrypy.org/"
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-LICENSE="BSD"
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_test() {
- cd cherrypy/test
- python test.py --dumb || die "Test failed."
-}
diff --git a/dev-python/cherrypy/cherrypy-3.0.1.ebuild b/dev-python/cherrypy/cherrypy-3.0.1.ebuild
index 2fbb16e31825..13f69a4e922a 100644
--- a/dev-python/cherrypy/cherrypy-3.0.1.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.1.ebuild,v 1.1 2007/02/27 21:10:21 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.1.ebuild,v 1.2 2007/02/27 22:47:19 dev-zero Exp $
inherit distutils
@@ -9,14 +9,35 @@ MY_P=CherryPy-${PV}
DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
HOMEPAGE="http://www.cherrypy.org/"
-IUSE=""
+IUSE="doc"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
LICENSE="BSD"
-S="${WORKDIR}/${MY_P}"
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/"cherrypy.tutorial",//' \
+ -e "/('cherrypy\/tutorial',/, /),/d" \
+ setup.py || die "sed failed"
+
+}
+
+src_install() {
+ distutils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r cherrypy/tutorial
+ fi
+}
src_test() {
- cd cherrypy/test
- ${python} test.py --dumb || die "Test failed."
+ PYTHONPATH=. "${python}" cherrypy/test/test.py --dumb || die "test failed"
}
diff --git a/dev-python/cherrypy/files/digest-cherrypy-2.2.1 b/dev-python/cherrypy/files/digest-cherrypy-2.2.1
new file mode 100644
index 000000000000..9c6163b20695
--- /dev/null
+++ b/dev-python/cherrypy/files/digest-cherrypy-2.2.1
@@ -0,0 +1,3 @@
+MD5 14bf17b0706bc480342cb8fcfaed74cd CherryPy-2.2.1.tar.gz 219932
+RMD160 c8f406c5eaedb6f710dc746528b8474df48cb3c8 CherryPy-2.2.1.tar.gz 219932
+SHA256 af83ef4f7b6ffabfccea2794cc61ca0f6fabf24c95901b22ea36e5407ffb794b CherryPy-2.2.1.tar.gz 219932
diff --git a/dev-python/cherrypy/files/digest-cherrypy-3.0.0 b/dev-python/cherrypy/files/digest-cherrypy-3.0.0
deleted file mode 100644
index 266adda27fa8..000000000000
--- a/dev-python/cherrypy/files/digest-cherrypy-3.0.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2065d19e79c9c1b30c9327509d2f3d0e CherryPy-3.0.0.tar.gz 253348
-RMD160 e162013d2b7cbb0ee1020c96653d7c26f6fa6481 CherryPy-3.0.0.tar.gz 253348
-SHA256 84dfd1661451c300d80eed214f9280f4caeae075833718a6e539e3f45c881561 CherryPy-3.0.0.tar.gz 253348