summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-30 20:42:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-30 20:42:22 +0000
commit0ee47348624527e791238867f10b778ccec2bd28 (patch)
tree2ba5c75bda9f75c94e528ec936ba5df01a9a529a /dev-python
parentVersion bump (diff)
downloadgentoo-2-0ee47348624527e791238867f10b778ccec2bd28.tar.gz
gentoo-2-0ee47348624527e791238867f10b778ccec2bd28.tar.bz2
gentoo-2-0ee47348624527e791238867f10b778ccec2bd28.zip
Version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pandas/ChangeLog8
-rw-r--r--dev-python/pandas/pandas-0.8.1.ebuild67
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-python/pandas/ChangeLog b/dev-python/pandas/ChangeLog
index 85714b7446d9..6b66ac4a9fe9 100644
--- a/dev-python/pandas/ChangeLog
+++ b/dev-python/pandas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pandas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.3 2012/06/21 18:33:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.4 2012/07/30 20:42:22 bicatali Exp $
+
+*pandas-0.8.1 (30 Jul 2012)
+
+ 30 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +pandas-0.8.1.ebuild:
+ Version bump
21 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> pandas-0.7.3.ebuild:
Restrict pypy
@@ -15,4 +20,3 @@
+metadata.xml:
Initial import from the science overlay + version bump. Added doc, testing
and extra dependencies.
-
diff --git a/dev-python/pandas/pandas-0.8.1.ebuild b/dev-python/pandas/pandas-0.8.1.ebuild
new file mode 100644
index 000000000000..c12df95f9090
--- /dev/null
+++ b/dev-python/pandas/pandas-0.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/pandas-0.8.1.ebuild,v 1.1 2012/07/30 20:42:22 bicatali Exp $
+
+EAPI=4
+
+# python cruft
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+RESTRICT_PYTHON_ABIS="2.4 2.7-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="Powerful data structures for data analysis and statistics"
+HOMEPAGE="http://pandas.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc examples excel R"
+
+CDEPEND="dev-python/numpy
+ >=dev-python/python-dateutil-2.1"
+DEPEND="${CDEPEND}
+ doc? (
+ dev-python/ipython
+ dev-python/rpy
+ dev-python/sphinx
+ sci-libs/scikits_statsmodels
+ )"
+RDEPEND="${CDEPEND}
+ dev-python/matplotlib
+ dev-python/pytables
+ dev-python/pytz
+ sci-libs/scipy
+ excel? (
+ dev-python/openpyxl
+ dev-python/xlrd
+ dev-python/xlwt
+ )
+ R? ( dev-python/rpy )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd doc
+ "$(PYTHON -f)" make.py html || die
+ fi
+}
+
+src_test() {
+ testing() {
+ cd "${S}/build-${PYTHON_ABI}"/lib*
+ PYTHONPATH=. nosetests-"${PYTHON_ABI}" pandas
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/build/html
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}