summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 06:29:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 06:29:25 +0000
commit09de0098182b579e3d1837fe86fa8cba1cb33750 (patch)
treed5b5b2162e6c7ee9f2529044e7134569ee007f4e /dev-python
parentVersion bump. (diff)
downloadgentoo-2-09de0098182b579e3d1837fe86fa8cba1cb33750.tar.gz
gentoo-2-09de0098182b579e3d1837fe86fa8cba1cb33750.tar.bz2
gentoo-2-09de0098182b579e3d1837fe86fa8cba1cb33750.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/github2/ChangeLog8
-rw-r--r--dev-python/github2/github2-0.6.2.ebuild28
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/github2/ChangeLog b/dev-python/github2/ChangeLog
index 53d7a3ee2a99..0321ce0eae63 100644
--- a/dev-python/github2/ChangeLog
+++ b/dev-python/github2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/github2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/github2/ChangeLog,v 1.3 2012/04/01 04:40:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/github2/ChangeLog,v 1.4 2012/06/28 06:29:25 patrick Exp $
+
+*github2-0.6.2 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +github2-0.6.2.ebuild:
+ Bump
01 Apr 2012; Mike Gilbert <floppym@gentoo.org> github2-0.6.0.ebuild,
github2-0.6.1.ebuild:
@@ -16,4 +21,3 @@
18 Feb 2012; Tim Harder <radhermit@gentoo.org> +github2-0.6.0.ebuild,
+metadata.xml:
Initial import (bug #378347). Ebuild by me.
-
diff --git a/dev-python/github2/github2-0.6.2.ebuild b/dev-python/github2/github2-0.6.2.ebuild
new file mode 100644
index 000000000000..d145f7f449d3
--- /dev/null
+++ b/dev-python/github2/github2-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/github2/github2-0.6.2.ebuild,v 1.1 2012/06/28 06:29:25 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+# Restricted until the third-party socks module is ported to Python 3
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Github API library"
+HOMEPAGE="https://github.com/ask/python-github2 http://pypi.python.org/pypi/github2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/httplib2-0.7.0
+ dev-python/python-dateutil"
+DEPEND="${RDEPEND}
+ test? ( dev-python/coverage
+ dev-python/mock )"