summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-28 15:57:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-28 15:57:49 +0000
commit05bad85d49e87da10f019b7f30d9dd845a19ffce (patch)
tree20ab5a0eb8eb4f0c5b47c490f36529ed9b1bb975 /dev-python
parentia64/sh/sparc stable wrt #427544 (diff)
downloadgentoo-2-05bad85d49e87da10f019b7f30d9dd845a19ffce.tar.gz
gentoo-2-05bad85d49e87da10f019b7f30d9dd845a19ffce.tar.bz2
gentoo-2-05bad85d49e87da10f019b7f30d9dd845a19ffce.zip
Version bump. Remove old
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/sip-4.12.3-r2.ebuild79
-rw-r--r--dev-python/sip/sip-4.13.2-r1.ebuild75
-rw-r--r--dev-python/sip/sip-4.14.1.ebuild107
4 files changed, 114 insertions, 155 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index b2c15a98f33e..4b6cdc0528ca 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.227 2012/10/14 21:43:25 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.228 2012/10/28 15:57:49 hwoarang Exp $
+
+*sip-4.14.1 (28 Oct 2012)
+
+ 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +sip-4.14.1.ebuild,
+ -sip-4.12.3-r2.ebuild, -sip-4.13.2-r1.ebuild:
+ Version bump. Remove old
14 Oct 2012; Davide Pesavento <pesa@gentoo.org> sip-4.14.ebuild:
Update from qt overlay.
diff --git a/dev-python/sip/sip-4.12.3-r2.ebuild b/dev-python/sip/sip-4.12.3-r2.ebuild
deleted file mode 100644
index b81d5a9bd021..000000000000
--- a/dev-python/sip/sip-4.12.3-r2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.3-r2.ebuild,v 1.7 2012/03/31 14:13:55 klausman Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit eutils python toolchain-funcs
-
-MY_P="${P/_pre/-snapshot-}"
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
- epatch "${FILESDIR}/${P}-python-3.2.patch"
- epatch "${FILESDIR}/${P}-sip_api_is_py_method.patch"
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --bindir="${EPREFIX}/usr/bin"
- --incdir="${EPREFIX}$(python_get_includedir)"
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
- LFLAGS="${LDFLAGS}"
- STRIP=":")
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn "When updating dev-python/sip, you usually need to rebuild packages, which depend on dev-python/sip,"
- ewarn "such as dev-python/PyQt4 and dev-python/qscintilla-python. If you have app-portage/gentoolkit"
- ewarn "installed, you can find these packages with \`equery d dev-python/sip dev-python/PyQt4\`."
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.13.2-r1.ebuild b/dev-python/sip/sip-4.13.2-r1.ebuild
deleted file mode 100644
index 818b839bd2b9..000000000000
--- a/dev-python/sip/sip-4.13.2-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.2-r1.ebuild,v 1.6 2012/07/08 18:25:51 armin76 Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit eutils python toolchain-funcs
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~ppc ~ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
- sed -i -e 's/-O2//g' specs/* || die
-
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --bindir="${EPREFIX}/usr/bin"
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --incdir="${EPREFIX}$(python_get_includedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- CFLAGS="${CFLAGS}"
- CXXFLAGS="${CXXFLAGS}"
- LFLAGS="${LDFLAGS}"
- STRIP=":")
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn "When updating dev-python/sip, you usually need to rebuild packages that depend on it,"
- ewarn "such as PyQt4, qscintilla-python and pykde4. If you have app-portage/gentoolkit"
- ewarn "installed, you can find these packages with \`equery d dev-python/sip\`."
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.14.1.ebuild b/dev-python/sip/sip-4.14.1.ebuild
new file mode 100644
index 000000000000..ad7b0ddf2933
--- /dev/null
+++ b/dev-python/sip/sip-4.14.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.14.1.ebuild,v 1.1 2012/10/28 15:57:49 hwoarang Exp $
+
+EAPI="5"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+
+if [[ ${PV} == *9999* ]]; then
+ # live version from mercurial repo
+ EHG_REPO_URI="http://www.riverbankcomputing.com/hg/sip"
+ inherit mercurial
+elif [[ ${PV} == *_pre* ]]; then
+ # development snapshot
+ HG_REVISION=
+ MY_P=${PN}-${PV%_pre*}-snapshot-${HG_REVISION}
+ SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ # official release
+ SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
+fi
+
+# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
+SLOT="0/9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+[[ ${PV} == *9999* ]] && DEPEND+="
+ sys-devel/bison
+ sys-devel/flex
+ doc? ( dev-python/sphinx )
+"
+
+src_prepare() {
+ if [[ ${PV} == *9999* ]]; then
+ $(PYTHON -2) build.py prepare || die
+ if use doc; then
+ $(PYTHON -2) build.py doc || die
+ fi
+ fi
+
+ # Sub-slot sanity check
+ local sub_slot=${SLOT#*/}
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
+ sed -i -e 's/-O2//g' specs/* || die
+
+ python_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --incdir="${EPREFIX}$(python_get_includedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LFLAGS="${LDFLAGS}"
+ STRIP=":")
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+
+ dodoc NEWS
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}