summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-09 14:53:30 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-09 14:53:30 +0000
commit0556fce44f57d3f66d509dbd33cb11fdc764c60d (patch)
tree9cf61fcdc052c104512d51c3d722f3f7f4caae9b /dev-python
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-0556fce44f57d3f66d509dbd33cb11fdc764c60d.tar.gz
gentoo-2-0556fce44f57d3f66d509dbd33cb11fdc764c60d.tar.bz2
gentoo-2-0556fce44f57d3f66d509dbd33cb11fdc764c60d.zip
Add PYTHON_USEDEP on nosetests.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyxdg/ChangeLog5
-rw-r--r--dev-python/pyxdg/pyxdg-0.25.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pyxdg/ChangeLog b/dev-python/pyxdg/ChangeLog
index 5225bb0fb9ec..e39ea8aa90a4 100644
--- a/dev-python/pyxdg/ChangeLog
+++ b/dev-python/pyxdg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyxdg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.101 2012/12/09 08:59:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.102 2012/12/09 14:53:30 mgorny Exp $
+
+ 09 Dec 2012; Michał Górny <mgorny@gentoo.org> pyxdg-0.25.ebuild:
+ Add PYTHON_USEDEP on nosetests.
*pyxdg-0.25 (09 Dec 2012)
diff --git a/dev-python/pyxdg/pyxdg-0.25.ebuild b/dev-python/pyxdg/pyxdg-0.25.ebuild
index 7da7ba743f42..2420e3b35279 100644
--- a/dev-python/pyxdg/pyxdg-0.25.ebuild
+++ b/dev-python/pyxdg/pyxdg-0.25.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.25.ebuild,v 1.1 2012/12/09 08:59:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.25.ebuild,v 1.2 2012/12/09 14:53:30 mgorny Exp $
EAPI=4
-PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+# py3.3 removed due to nosetests
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy{1_8,1_9} )
inherit distutils-r1
DESCRIPTION="A Python module to deal with freedesktop.org specifications"
@@ -16,7 +17,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="test"
-DEPEND="test? ( dev-python/nose )"
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
DOCS=( AUTHORS ChangeLog README TODO )