summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-13 03:04:52 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-13 03:04:52 +0000
commitff119759bbf64bbb75bd32cf2da4ee5c16e29a4b (patch)
tree4d8c52bfb1f5e2d0de7098357ec36ef8b35fe36a /dev-python/yolk
parentDon't inherit unused eclass. Patch by Arfrever. (diff)
downloadgentoo-2-ff119759bbf64bbb75bd32cf2da4ee5c16e29a4b.tar.gz
gentoo-2-ff119759bbf64bbb75bd32cf2da4ee5c16e29a4b.tar.bz2
gentoo-2-ff119759bbf64bbb75bd32cf2da4ee5c16e29a4b.zip
Use EAPI=4. Don't inherit unused eclass. Fix dependencies. Patch by Arfrever.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/yolk')
-rw-r--r--dev-python/yolk/ChangeLog5
-rw-r--r--dev-python/yolk/yolk-0.4.3.ebuild17
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/yolk/ChangeLog b/dev-python/yolk/ChangeLog
index 891aae025542..90c86214a8c3 100644
--- a/dev-python/yolk/ChangeLog
+++ b/dev-python/yolk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/yolk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.14 2012/03/09 08:08:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.15 2012/03/13 03:04:52 floppym Exp $
+
+ 13 Mar 2012; Mike Gilbert <floppym@gentoo.org> yolk-0.4.3.ebuild:
+ Use EAPI=4. Don't inherit unused eclass. Fix dependencies. Patch by Arfrever.
*yolk-0.4.3 (09 Mar 2012)
diff --git a/dev-python/yolk/yolk-0.4.3.ebuild b/dev-python/yolk/yolk-0.4.3.ebuild
index 3caa71ca50fd..bc2c587c81c3 100644
--- a/dev-python/yolk/yolk-0.4.3.ebuild
+++ b/dev-python/yolk/yolk-0.4.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.4.3.ebuild,v 1.1 2012/03/09 08:08:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.4.3.ebuild,v 1.2 2012/03/13 03:04:52 floppym Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit eutils distutils
+inherit distutils
DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
HOMEPAGE="http://pypi.python.org/pypi/yolk"
@@ -18,18 +18,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND="dev-python/setuptools"
-RDEPEND="dev-python/yolk-portage"
+DEPEND="dev-python/setuptools
+ dev-python/yolk-portage"
+RDEPEND="${DEPEND}"
src_install() {
distutils_src_install
if use examples; then
docinto examples/plugins
- dodoc examples/plugins/*
- docinto examples/plugins/yolk_portage
- dodoc examples/plugins/yolk_portage/*
- docinto examples/plugins/yolk_pkg_manager
- dodoc examples/plugins/yolk_pkg_manager/*
+ dodoc -r examples/plugins/*
fi
}