summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:31:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-30 00:31:30 +0000
commit0b09fba77cc826ef57671d86e7b7b93fef7e83a7 (patch)
tree5bf1373b524c5133227e28aa06474252ac570d25 /dev-python/yolk
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-0b09fba77cc826ef57671d86e7b7b93fef7e83a7.tar.gz
gentoo-2-0b09fba77cc826ef57671d86e7b7b93fef7e83a7.tar.bz2
gentoo-2-0b09fba77cc826ef57671d86e7b7b93fef7e83a7.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/yolk')
-rw-r--r--dev-python/yolk/ChangeLog8
-rw-r--r--dev-python/yolk/yolk-0.4.1.ebuild24
2 files changed, 21 insertions, 11 deletions
diff --git a/dev-python/yolk/ChangeLog b/dev-python/yolk/ChangeLog
index 3f7718da15d6..329289f01ea5 100644
--- a/dev-python/yolk/ChangeLog
+++ b/dev-python/yolk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/yolk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.9 2009/04/24 14:29:03 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.10 2010/06/30 00:31:30 arfrever Exp $
+
+ 30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ yolk-0.4.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
24 Apr 2009; Patrick Lauer <patrick@gentoo.org> -yolk-0.3.0.ebuild:
Remove old
diff --git a/dev-python/yolk/yolk-0.4.1.ebuild b/dev-python/yolk/yolk-0.4.1.ebuild
index 99f484eaccf0..d83c7298ea58 100644
--- a/dev-python/yolk/yolk-0.4.1.ebuild
+++ b/dev-python/yolk/yolk-0.4.1.ebuild
@@ -1,30 +1,36 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.4.1.ebuild,v 1.1 2009/02/15 13:46:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.4.1.ebuild,v 1.2 2010/06/30 00:31:30 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
-HOMEPAGE="http://cheeseshop.python.org/pypi/yolk"
-SRC_URI="http://cheeseshop.python.org/packages/source/y/yolk/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/yolk"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
+
DEPEND="dev-python/setuptools"
RDEPEND="dev-python/yolk-portage"
src_install() {
distutils_src_install
- if use examples ; then
+
+ if use examples; then
docinto examples/plugins
- dodoc "${S}"/examples/plugins/*
+ dodoc examples/plugins/*
docinto examples/plugins/yolk_portage
- dodoc "${S}"/examples/plugins/yolk_portage/*
+ dodoc examples/plugins/yolk_portage/*
docinto examples/plugins/yolk_pkg_manager
- dodoc "${S}"/examples/plugins/yolk_pkg_manager/*
+ dodoc examples/plugins/yolk_pkg_manager/*
prepalldocs
fi
}