summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-22 13:49:08 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-22 13:49:08 +0000
commit358ce899909663a899302e72ee517d5d7ebb6f14 (patch)
tree82698d4630cead5b90b48803122f6fbfd10adc85 /dev-python/wxpython
parentppc stable, bug #202174 (diff)
downloadgentoo-2-358ce899909663a899302e72ee517d5d7ebb6f14.tar.gz
gentoo-2-358ce899909663a899302e72ee517d5d7ebb6f14.tar.bz2
gentoo-2-358ce899909663a899302e72ee517d5d7ebb6f14.zip
Lock DEPEND to wxGTK-2.6 for bug #202998.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/wxpython-2.6.3.3.ebuild4
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild10
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0.ebuild8
4 files changed, 16 insertions, 12 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index d50db8e189dd..f158f038711c 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.71 2007/12/13 04:09:12 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.72 2007/12/22 13:49:08 dirtyepic Exp $
+
+ 22 Dec 2007; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.3.3.ebuild,
+ wxpython-2.6.4.0.ebuild, wxpython-2.6.4.0-r1.ebuild:
+ Lock DEPEND to wxGTK-2.6 for bug #202998.
13 Dec 2007; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0-r1.ebuild:
Drop arm, ppc, sh, and x86-fbsd keywords for bug #199594.
diff --git a/dev-python/wxpython/wxpython-2.6.3.3.ebuild b/dev-python/wxpython/wxpython-2.6.3.3.ebuild
index ccff46aac0e5..c62195d6d872 100644
--- a/dev-python/wxpython/wxpython-2.6.3.3.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.16 2007/09/22 00:58:13 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.3.3.ebuild,v 1.17 2007/12/22 13:49:08 dirtyepic Exp $
inherit python wxwidgets eutils multilib
@@ -15,7 +15,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="unicode opengl"
RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}
+ =x11-libs/wxGTK-2.6*
>=x11-libs/gtk+-2.0
>=x11-libs/pango-1.2
>=dev-libs/glib-2.0
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index 708b2517c0b8..18d94c2892e6 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.3 2007/12/13 04:09:12 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.4 2007/12/22 13:49:08 dirtyepic Exp $
-WX_GTK_VER="2.6"
+EAPI=1
inherit alternatives eutils multilib python wxwidgets
@@ -17,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
IUSE="opengl unicode"
RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}
+ >=x11-libs/wxGTK-${PV}:2.6
>=x11-libs/gtk+-2.0
>=x11-libs/pango-1.2
>=dev-libs/glib-2.0
@@ -25,8 +25,7 @@ RDEPEND=">=dev-lang/python-2.1
media-libs/jpeg
media-libs/tiff
>=sys-libs/zlib-1.1.4
- opengl? ( >=dev-python/pyopengl-2.0.0.44 )
- !<dev-python/wxpython-2.4.2.4-r1"
+ opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -42,6 +41,7 @@ src_unpack() {
src_compile() {
local mypyconf
+ WX_GTK_VER="2.6"
if use unicode; then
need-wxwidgets unicode
diff --git a/dev-python/wxpython/wxpython-2.6.4.0.ebuild b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
index 3862d7df735d..5561e93078d3 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.10 2007/11/04 14:34:10 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.11 2007/12/22 13:49:08 dirtyepic Exp $
inherit python wxwidgets eutils multilib
@@ -15,7 +15,7 @@ KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
IUSE="unicode opengl"
RDEPEND=">=dev-lang/python-2.1
- >=x11-libs/wxGTK-${PV}
+ ~x11-libs/wxGTK-${PV}
>=x11-libs/gtk+-2.0
>=x11-libs/pango-1.2
>=dev-libs/glib-2.0
@@ -31,8 +31,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}/wxPython/"
-WX_GTK_VER="2.6"
-
pkg_setup() {
echo
use opengl && check_wxuse opengl
@@ -49,6 +47,8 @@ src_unpack() {
src_compile() {
local mypyconf
+ WX_GTK_VER="2.6"
+
if use unicode; then
need-wxwidgets unicode
else