summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-08-30 17:09:43 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-08-30 17:09:43 +0000
commit79c5be102f0ca4f5c5a327411104a75bf0a7e890 (patch)
treed97fa04ed6c88c0d9cdf453c60761622b65e2b5b /dev-python/wxpython/wxpython-2.8.10.1.ebuild
parentRemove old, quote variables for repoman happiness. (diff)
downloadgentoo-2-79c5be102f0ca4f5c5a327411104a75bf0a7e890.tar.gz
gentoo-2-79c5be102f0ca4f5c5a327411104a75bf0a7e890.tar.bz2
gentoo-2-79c5be102f0ca4f5c5a327411104a75bf0a7e890.zip
Revert usage of += operators. They're a bash-3.1 feature and PMS is stuck
at bash-3.0. (Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/wxpython/wxpython-2.8.10.1.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.8.10.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/wxpython/wxpython-2.8.10.1.ebuild b/dev-python/wxpython/wxpython-2.8.10.1.ebuild
index 8094fd01cc2e..8eea26883873 100644
--- a/dev-python/wxpython/wxpython-2.8.10.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.10.1.ebuild,v 1.2 2009/08/29 19:52:14 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.10.1.ebuild,v 1.3 2009/08/30 17:09:43 dirtyepic Exp $
EAPI="2"
WX_GTK_VER="2.8"
@@ -69,11 +69,11 @@ src_configure() {
append-flags -fno-strict-aliasing
use opengl \
- && mypyconf+=" BUILD_GLCANVAS=1" \
- || mypyconf+=" BUILD_GLCANVAS=0"
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
- mypyconf+=" WX_CONFIG=${WX_CONFIG}"
- mypyconf+=" WXPORT=gtk2 UNICODE=1"
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
}
src_compile() {
@@ -86,12 +86,12 @@ src_compile() {
src_install() {
local mypyconf
- mypyconf+=" WX_CONFIG=${WX_CONFIG}"
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
- && mypyconf+=" BUILD_GLCANVAS=1" \
- || mypyconf+=" BUILD_GLCANVAS=0"
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
- mypyconf+=" WXPORT=gtk2 UNICODE=1"
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
installation() {
"$(PYTHON)" setup.py ${mypyconf} install --root="${D}" --install-purelib $(python_get_sitedir)