summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-24 02:31:04 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-24 02:31:04 +0000
commit1e9c9936cde79928bddcfa245b7ce5d3b8878a63 (patch)
tree4976b38c1f0f7997f43e43dcc73d15750026a034 /dev-python/ws4py
parentDisable automatic ssp flags -- this is the realm of user flags. (diff)
downloadgentoo-2-1e9c9936cde79928bddcfa245b7ce5d3b8878a63.tar.gz
gentoo-2-1e9c9936cde79928bddcfa245b7ce5d3b8878a63.tar.bz2
gentoo-2-1e9c9936cde79928bddcfa245b7ce5d3b8878a63.zip
Further refine client/server install and gevent requirement.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/ChangeLog8
-rw-r--r--dev-python/ws4py/metadata.xml4
-rw-r--r--dev-python/ws4py/ws4py-0.2.1-r2.ebuild46
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild30
4 files changed, 77 insertions, 11 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index 8bfd1af6a69e..5d1588b6c7d6 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/ws4py
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.2 2012/04/20 19:37:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.3 2012/04/24 02:31:04 vapier Exp $
+
+*ws4py-0.2.1-r2 (24 Apr 2012)
+
+ 24 Apr 2012; Mike Frysinger <vapier@gentoo.org> +ws4py-0.2.1-r2.ebuild,
+ metadata.xml, ws4py-9999.ebuild:
+ Further refine client/server install and gevent requirement.
*ws4py-0.2.1-r1 (20 Apr 2012)
diff --git a/dev-python/ws4py/metadata.xml b/dev-python/ws4py/metadata.xml
index 80f2c021cdaf..13bc2c4ff5bb 100644
--- a/dev-python/ws4py/metadata.xml
+++ b/dev-python/ws4py/metadata.xml
@@ -6,4 +6,8 @@
<email>vapier@gentoo.org</email>
<description>make whatever changes you want</description>
</maintainer>
+<use>
+ <flag name='client'>Install client modules</flag>
+ <flag name='server'>Install server modules</flag>
+</use>
</pkgmetadata>
diff --git a/dev-python/ws4py/ws4py-0.2.1-r2.ebuild b/dev-python/ws4py/ws4py-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..673f27752192
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.2.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.2.1-r2.ebuild,v 1.1 2012/04/24 02:31:04 vapier Exp $
+
+# The gevent package isn't in the tree yet, so we delete
+# those implementations.
+#
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}-src.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server +threads"
+
+RDEPEND="client? ( dev-lang/python[threads?] )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-process-data.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ # We don't have a gevent pkg in the tree, so punt.
+ rm -rf "${ED}$(python_get_sitedir)"/ws4py/*/gevent*.py
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 10b73c7a38f7..349af5e0e9b9 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,11 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-9999.ebuild,v 1.1 2012/04/17 23:09:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-9999.ebuild,v 1.2 2012/04/24 02:31:04 vapier Exp $
+
+# The gevent package isn't in the tree yet, so we delete
+# those implementations.
+#
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
EAPI="4"
PYTHON_DEPEND="2"
-inherit distutils
+inherit distutils eutils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
inherit git-2
@@ -20,17 +27,20 @@ HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
LICENSE="BSD"
SLOT="0"
-IUSE=""
-#IUSE="client server"
+IUSE="+client +server +threads"
-# The gevent package isn't in the tree yet.
-#RDEPEND="client? ( >=dev-python/gevent-0.13.6 )
-# server? ( >=dev-python/gevent-0.13.6 )"
+RDEPEND="client? ( dev-lang/python[threads?] )"
DEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-process-data.patch
+ distutils_src_prepare
+}
+
src_install() {
distutils_src_install
- #use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
- #use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
- rm -rf "${ED}$(python_get_sitedir)"/ws4py/{client,server}
+ # We don't have a gevent pkg in the tree, so punt.
+ rm -rf "${ED}$(python_get_sitedir)"/ws4py/*/gevent*.py
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
}