summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-08-04 12:02:26 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-08-04 12:02:26 +0000
commitd096d2b1e9bcafeb70c02c9c238d13cb0e8e4c6a (patch)
treef466c695c2710d24b81c8dc203029b34ac6e7c05 /dev-python/werkzeug
parentVersion bump, remove old. (diff)
downloadgentoo-2-d096d2b1e9bcafeb70c02c9c238d13cb0e8e4c6a.tar.gz
gentoo-2-d096d2b1e9bcafeb70c02c9c238d13cb0e8e4c6a.tar.bz2
gentoo-2-d096d2b1e9bcafeb70c02c9c238d13cb0e8e4c6a.zip
Fixing installation of docs, removing old
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog9
-rw-r--r--dev-python/werkzeug/werkzeug-0.3.1-r1.ebuild (renamed from dev-python/werkzeug/werkzeug-0.2.ebuild)12
-rw-r--r--dev-python/werkzeug/werkzeug-0.3.1.ebuild34
3 files changed, 18 insertions, 37 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index 4144cc9deff0..559447fc6610 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.3 2008/07/20 13:31:12 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.4 2008/08/04 12:02:26 hoffie Exp $
+
+*werkzeug-0.3.1-r1 (04 Aug 2008)
+
+ 04 Aug 2008; Christian Hoffmann <hoffie@gentoo.org> -werkzeug-0.2.ebuild,
+ -werkzeug-0.3.1.ebuild, +werkzeug-0.3.1-r1.ebuild:
+ Fixing installation of docs (they went to /usr/docs/ directly), cleaning
+ old
*werkzeug-0.3.1 (20 Jul 2008)
diff --git a/dev-python/werkzeug/werkzeug-0.2.ebuild b/dev-python/werkzeug/werkzeug-0.3.1-r1.ebuild
index 24b526ae92bc..28f3095c64d8 100644
--- a/dev-python/werkzeug/werkzeug-0.2.ebuild
+++ b/dev-python/werkzeug/werkzeug-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.2.ebuild,v 1.2 2008/03/15 23:23:23 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.3.1-r1.ebuild,v 1.1 2008/08/04 12:02:26 hoffie Exp $
NEED_PYTHON="2.4"
@@ -24,7 +24,15 @@ DEPEND=">=dev-python/setuptools-0.6_rc5
S="${WORKDIR}/${MY_P}"
-DOCS="CHANGES"
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ # Rearraning the docs
+ rm -rf "${D}/usr/docs"
+ dodoc docs/src/*
+ dohtml docs/html/*
+}
src_test() {
distutils_python_version
diff --git a/dev-python/werkzeug/werkzeug-0.3.1.ebuild b/dev-python/werkzeug/werkzeug-0.3.1.ebuild
deleted file mode 100644
index 0e15629fc3bc..000000000000
--- a/dev-python/werkzeug/werkzeug-0.3.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.3.1.ebuild,v 1.1 2008/07/20 13:31:12 hoffie Exp $
-
-NEED_PYTHON="2.4"
-
-inherit distutils
-
-MY_P="Werkzeug-${PV}"
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="http://werkzeug.pocoo.org/"
-SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=""
-DEPEND=">=dev-python/setuptools-0.6_rc5
- test? ( dev-python/py
- dev-python/lxml
- dev-python/simplejson )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_test() {
- distutils_python_version
- # path gets set correctly in conftest.py
- cd tests
- py.test || die "tests failed"
-}