summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-12-03 21:39:52 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-12-03 21:39:52 +0000
commit3901ec06ace76de7e422512d8a7bc206d8489170 (patch)
tree3d061e7f1aa68b01b3b5a377e9f9d1c856267e43 /dev-python/werkzeug
parentremove older 0.9.x versions since 0.9.4 is going stable. (diff)
downloadgentoo-2-3901ec06ace76de7e422512d8a7bc206d8489170.tar.gz
gentoo-2-3901ec06ace76de7e422512d8a7bc206d8489170.tar.bz2
gentoo-2-3901ec06ace76de7e422512d8a7bc206d8489170.zip
Version bump. Thanks to Johan Bergström (bug #392903) and Arfrever.
(Portage version: 2.2.0_alpha59_p57/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog8
-rw-r--r--dev-python/werkzeug/werkzeug-0.8.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index 44599a9530b1..42b878d146af 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.26 2011/09/13 23:52:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.27 2011/12/03 21:39:52 rafaelmartins Exp $
+
+*werkzeug-0.8.1 (03 Dec 2011)
+
+ 03 Dec 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +werkzeug-0.8.1.ebuild:
+ Version bump. Thanks to Johan Bergström (bug #392903) and Arfrever.
*werkzeug-0.7.1-r1 (13 Sep 2011)
diff --git a/dev-python/werkzeug/werkzeug-0.8.1.ebuild b/dev-python/werkzeug/werkzeug-0.8.1.ebuild
new file mode 100644
index 000000000000..b32472475473
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.8.1.ebuild,v 1.1 2011/12/03 21:39:52 rafaelmartins Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ http://pypi.python.org/pypi/Werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/lxml )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable redis-related tests.
+ # https://github.com/mitsuhiko/werkzeug/issues/120
+ sed -e "s/import redis/redis = None/" -i werkzeug/testsuite/contrib/cache.py
+}
+