summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-20 07:46:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-20 07:46:32 +0000
commit4737a3b3fda8b57ad09ee09e88c5f946ac244de2 (patch)
tree5eb99e1322bd1cdf76e6cea885ed69f453f95526 /dev-python/webtest
parentVersion bump. (diff)
downloadgentoo-2-4737a3b3fda8b57ad09ee09e88c5f946ac244de2.tar.gz
gentoo-2-4737a3b3fda8b57ad09ee09e88c5f946ac244de2.tar.bz2
gentoo-2-4737a3b3fda8b57ad09ee09e88c5f946ac244de2.zip
clean old impl, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog7
-rw-r--r--dev-python/webtest/webtest-1.3.3-r1.ebuild68
-rw-r--r--dev-python/webtest/webtest-1.4.3.ebuild57
-rw-r--r--dev-python/webtest/webtest-2.0.11.ebuild72
-rw-r--r--dev-python/webtest/webtest-2.0.14.ebuild72
-rw-r--r--dev-python/webtest/webtest-2.0.15.ebuild4
6 files changed, 8 insertions, 272 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 1e6bd0e91c4c..86790000f757 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.89 2014/10/27 12:35:27 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.90 2014/12/20 07:46:32 idella4 Exp $
+
+ 20 Dec 2014; Ian Delaney <idella4@gentoo.org> -webtest-1.3.3-r1.ebuild,
+ -webtest-1.4.3.ebuild, -webtest-2.0.11.ebuild, -webtest-2.0.14.ebuild,
+ webtest-2.0.15.ebuild, webtest-2.0.16.ebuild:
+ clean old impl, rm old
*webtest-2.0.16 (27 Oct 2014)
diff --git a/dev-python/webtest/webtest-1.3.3-r1.ebuild b/dev-python/webtest/webtest-1.3.3-r1.ebuild
deleted file mode 100644
index 5e48c27e5953..000000000000
--- a/dev-python/webtest/webtest-1.3.3-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.3.3-r1.ebuild,v 1.1 2013/09/12 06:07:43 prometheanfire Exp $
-
-#Needed by sys-cluster/keystone[test]
-
-EAPI="5"
-PYTHON_COMPAT=( python2_6 python2_7 )
-#restricted for failing test :(
-RESTRICT="test"
-
-inherit distutils-r1 eutils
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/webob-0.9.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.4-index_fixt.patch"
- distutils-r1_python_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- if use doc; then
- einfo "Generation of documentation"
- sphinx-build docs html || die "Building of documentation failed"
- fi
-}
-
-python_test() {
- "${PYTHON}" setup.py nosetests || die
-}
-
-python_install() {
- distutils-r1_python_install_all
-
- # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
- #removing since we don't support python 2.5 :D
- #delete_lint3() {
- # [[ "${PYTHON_ABI}" == 3.* ]] && return
- # rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
- #}
- #python-r1_execute_function -q delete_lint3
-
- if use doc; then
- dohtml -r html/*
- fi
-}
diff --git a/dev-python/webtest/webtest-1.4.3.ebuild b/dev-python/webtest/webtest-1.4.3.ebuild
deleted file mode 100644
index 660f528c5d3e..000000000000
--- a/dev-python/webtest/webtest-1.4.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.4.3.ebuild,v 1.11 2013/04/02 13:20:07 ago Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6 3:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.1"
-PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=dev-python/webob-0.9.2"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/pyquery )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- sphinx-build docs html || die "Building of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- # Avoid future-import bug on py2.5.* - lint3 is py3 anyway
- delete_lint3() {
- [[ "${PYTHON_ABI}" == 3.* ]] && return
- rm "${ED}$(python_get_sitedir)/webtest/lint3.py"
- }
- python_execute_function -q delete_lint3
-
- if use doc; then
- dohtml -r html/*
- fi
-}
diff --git a/dev-python/webtest/webtest-2.0.11.ebuild b/dev-python/webtest/webtest-2.0.11.ebuild
deleted file mode 100644
index 2e5afa983610..000000000000
--- a/dev-python/webtest/webtest-2.0.11.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.11.ebuild,v 1.5 2014/10/15 23:15:54 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- >=dev-python/webob-0.9.2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die
- fi
-}
-
-src_test() {
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-python_test() {
- # Tests raise ImportErrors with our default PYTHONPATH.
- local -x PYTHONPATH=
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Why is it so?
- if [[ ${EPYTHON} == python3* ]]; then
- rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/webtest/webtest-2.0.14.ebuild b/dev-python/webtest/webtest-2.0.14.ebuild
deleted file mode 100644
index 16a73e12bd02..000000000000
--- a/dev-python/webtest/webtest-2.0.14.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.14.ebuild,v 1.3 2014/10/15 23:15:54 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- >=dev-python/webob-0.9.2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die
- fi
-}
-
-src_test() {
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-python_test() {
- # Tests raise ImportErrors with our default PYTHONPATH.
- local -x PYTHONPATH=
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Why is it so?
- if [[ ${EPYTHON} == python3* ]]; then
- rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/webtest/webtest-2.0.15.ebuild b/dev-python/webtest/webtest-2.0.15.ebuild
index 0f6e9f760cef..4df4794c98ff 100644
--- a/dev-python/webtest/webtest-2.0.15.ebuild
+++ b/dev-python/webtest/webtest-2.0.15.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.15.ebuild,v 1.7 2014/10/25 14:02:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.15.ebuild,v 1.8 2014/12/20 07:46:32 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1