summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-05-25 10:28:24 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-05-25 10:28:24 +0000
commit6b662d57d9610799178033488006687aea648ad4 (patch)
tree9e4b45c4589dad979a1f9ad3005fdf2566b488fd /dev-python/webpy/webpy-0.34.ebuild
parentAllow usage of minitest with Ruby 1.9 as well, as the interfaces are not the ... (diff)
downloadgentoo-2-6b662d57d9610799178033488006687aea648ad4.tar.gz
gentoo-2-6b662d57d9610799178033488006687aea648ad4.tar.bz2
gentoo-2-6b662d57d9610799178033488006687aea648ad4.zip
Version bump dev-python/webpy to 0.34, bug 311097.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webpy/webpy-0.34.ebuild')
-rw-r--r--dev-python/webpy/webpy-0.34.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/webpy/webpy-0.34.ebuild b/dev-python/webpy/webpy-0.34.ebuild
new file mode 100644
index 000000000000..f8f45fffbe8b
--- /dev/null
+++ b/dev-python/webpy/webpy-0.34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.34.ebuild,v 1.1 2010/05/25 10:28:24 djc Exp $
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for python"
+HOMEPAGE="http://www.webpy.org"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/web.py-${PV}"
+PYTHON_MODNAME="web"
+
+src_test() {
+ TESTS="db template net http utils"
+
+ cd "${S}"
+
+ for TEST in ${TESTS}
+ do
+ ${python} web/${TEST}.py || die "Doctest in web/${TEST}.py failed!"
+ done
+}