summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 14:32:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 14:32:44 +0000
commit2ac9d3054a0322acb9b0beebaaa7475a957eaca3 (patch)
tree0d7eb9de6bf9ba87198aaf72e6bc0f99b5417302 /dev-python/weberror/weberror-0.10.3.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-2ac9d3054a0322acb9b0beebaaa7475a957eaca3.tar.gz
gentoo-2-2ac9d3054a0322acb9b0beebaaa7475a957eaca3.tar.bz2
gentoo-2-2ac9d3054a0322acb9b0beebaaa7475a957eaca3.zip
Version bump.
(Portage version: 2.2.0_alpha4_p23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/weberror/weberror-0.10.3.ebuild')
-rw-r--r--dev-python/weberror/weberror-0.10.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/weberror/weberror-0.10.3.ebuild b/dev-python/weberror/weberror-0.10.3.ebuild
new file mode 100644
index 000000000000..97f0063e5e1a
--- /dev/null
+++ b/dev-python/weberror/weberror-0.10.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weberror/weberror-0.10.3.ebuild,v 1.1 2010/11/15 14:32:44 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="WebError"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Web Error handling and exception catching"
+HOMEPAGE="http://pypi.python.org/pypi/WebError"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
+ >=dev-python/paste-1.7.1
+ dev-python/pygments
+ dev-python/setuptools
+ dev-python/tempita
+ dev-python/webob"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest )"
+
+S="${WORKDIR}/${MY_P}"