summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-12 06:59:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-12 06:59:15 +0000
commit7e788891a2f1532bdbd272dbea3d4d61ce34fc0a (patch)
tree11583917e29126a7a076257511ee23e96729ade3 /dev-python/waitress
parentfix for CVE-2013-4278 for bug 482144 (diff)
downloadgentoo-2-7e788891a2f1532bdbd272dbea3d4d61ce34fc0a.tar.gz
gentoo-2-7e788891a2f1532bdbd272dbea3d4d61ce34fc0a.tar.bz2
gentoo-2-7e788891a2f1532bdbd272dbea3d4d61ce34fc0a.zip
Bump
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/ChangeLog7
-rw-r--r--dev-python/waitress/waitress-0.8.7.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/waitress/ChangeLog b/dev-python/waitress/ChangeLog
index 140f123faba8..32c8d38be3d3 100644
--- a/dev-python/waitress/ChangeLog
+++ b/dev-python/waitress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/waitress
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/ChangeLog,v 1.4 2013/08/26 01:58:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/ChangeLog,v 1.5 2013/09/12 06:59:15 patrick Exp $
+
+*waitress-0.8.7 (12 Sep 2013)
+
+ 12 Sep 2013; Patrick Lauer <patrick@gentoo.org> +waitress-0.8.7.ebuild:
+ Bump
*waitress-0.8.6 (26 Aug 2013)
diff --git a/dev-python/waitress/waitress-0.8.7.ebuild b/dev-python/waitress/waitress-0.8.7.ebuild
new file mode 100644
index 000000000000..705bb4425163
--- /dev/null
+++ b/dev-python/waitress/waitress-0.8.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/waitress/waitress-0.8.7.ebuild,v 1.1 2013/09/12 06:59:15 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+# doc creation is fatally broken
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="http://docs.pylonsproject.org/projects/waitress/en/latest/ https://pypi.python.org/pypi/waitress/ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? ( dev-python/nose )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}