summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-04-03 00:24:53 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-04-03 00:24:53 +0000
commitd6b41726fc1b7f4775eac021cfb04bf5a20dfaa3 (patch)
treea2c70cba57008603c5fdbbda10797eee0ec1c51c /dev-python/virtualenv
parentRestore keywords that were dropped, after getting package visibility in order... (diff)
downloadgentoo-2-d6b41726fc1b7f4775eac021cfb04bf5a20dfaa3.tar.gz
gentoo-2-d6b41726fc1b7f4775eac021cfb04bf5a20dfaa3.tar.bz2
gentoo-2-d6b41726fc1b7f4775eac021cfb04bf5a20dfaa3.zip
Initial commit. Closes #215959
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/ChangeLog10
-rw-r--r--dev-python/virtualenv/Manifest4
-rw-r--r--dev-python/virtualenv/metadata.xml5
-rw-r--r--dev-python/virtualenv/virtualenv-1.0.ebuild24
4 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/virtualenv/ChangeLog b/dev-python/virtualenv/ChangeLog
new file mode 100644
index 000000000000..a35f068ed24c
--- /dev/null
+++ b/dev-python/virtualenv/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/virtualenv
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/ChangeLog,v 1.1 2008/04/03 00:24:53 pythonhead Exp $
+
+*virtualenv-1.0 (03 Apr 2008)
+
+ 03 Apr 2008; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+ +virtualenv-1.0.ebuild:
+ Initial commit. Closes #215959
+
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
new file mode 100644
index 000000000000..21186ef542af
--- /dev/null
+++ b/dev-python/virtualenv/Manifest
@@ -0,0 +1,4 @@
+DIST virtualenv-1.0.tar.gz 681618 RMD160 93768fe36940c41769b62516bc91c8d053ed6895 SHA1 a20331a0060834bf93c86df16de3bb65faa14653 SHA256 70bd71debfbf4941dbb3f0213a9711de8e10d092ab84b87e81a1195aa823e6c3
+EBUILD virtualenv-1.0.ebuild 499 RMD160 a098ed38c48050ad74dd80409371d8e51c0df6b3 SHA1 dcbf7305789c5c948578f95b208468b94820a669 SHA256 6bb7b8dfa4fc1841facd2852bcb6ae6ecf246709cdb4ec618efd0ec7d7943f6c
+MISC ChangeLog 281 RMD160 464174f48bafa69c1007d8c154cd2f274f07976d SHA1 f4d8da1d723228eaff2264343b710ad2998d2b16 SHA256 d9dfc4391b2f358cfc146bd37d34aa4538e592f3e703146a70860770a8c8455b
+MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/virtualenv/metadata.xml b/dev-python/virtualenv/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/virtualenv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/virtualenv/virtualenv-1.0.ebuild b/dev-python/virtualenv/virtualenv-1.0.ebuild
new file mode 100644
index 000000000000..1250515d59de
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/virtualenv-1.0.ebuild,v 1.1 2008/04/03 00:24:53 pythonhead Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="http://pypi.python.org/pypi/virtualenv"
+SRC_URI="http://pypi.python.org/packages/source/v/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-python/setuptools-0.6_rc7-r1"
+DOCS="docs/index.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm ez_setup.py
+}
+