summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-05-10 00:29:42 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-05-10 00:29:42 +0000
commit5a57b8abe03a1b7237ca94208ca328735f8671e5 (patch)
treed74cd8c62fe9ea1292fbc3863664cdb71fbe145d /dev-python/urwid
parentChange package name in ChangeLog header. (diff)
downloadgentoo-2-5a57b8abe03a1b7237ca94208ca328735f8671e5.tar.gz
gentoo-2-5a57b8abe03a1b7237ca94208ca328735f8671e5.tar.bz2
gentoo-2-5a57b8abe03a1b7237ca94208ca328735f8671e5.zip
Version bump. Thanks Daniel Feliciano Branco <danielblues@yahoo.com>
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog7
-rw-r--r--dev-python/urwid/Manifest16
-rw-r--r--dev-python/urwid/files/digest-urwid-0.8.71
-rw-r--r--dev-python/urwid/urwid-0.8.7.ebuild30
4 files changed, 41 insertions, 13 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 6b5e1410e83b..8f4b742573d2 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.4 2005/02/27 10:31:50 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.5 2005/05/10 00:29:42 pythonhead Exp $
+
+*urwid-0.8.7 (10 May 2005)
+
+ 10 May 2005; Rob Cakebread <pythonhead@gentoo.org> +urwid-0.8.7.ebuild:
+ Version bump. Thanks Daniel Feliciano Branco <danielblues@yahoo.com>
27 Feb 2005; Lukasz Strzygowski <lucass@gentoo.org> metadata.xml,
urwid-0.8.6.ebuild:
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 2e7361e64989..c0ef8da4633f 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 eb65fb620b681feb59a39173ec2bbaeb ChangeLog 668
-MD5 26d7d704ca382b7d9271064f1011385b metadata.xml 855
MD5 f367b6d77406960c7d3d3b8151f25712 urwid-0.8.6.ebuild 747
+MD5 26d7d704ca382b7d9271064f1011385b metadata.xml 855
+MD5 eb65fb620b681feb59a39173ec2bbaeb ChangeLog 668
+MD5 157e61a375f04048c535cceffaa9af0e urwid-0.8.7.ebuild 757
MD5 84b7b6bba847f6a4f3c63695b607eb8a files/digest-urwid-0.8.6 62
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCIaJt2jLqHNfbg2URAjpnAKDAn+c61ZRKbWEpQWF3XXJnQH/swQCdHfUK
-tt8Nsx/Bvfaz9f4TXeFQmBc=
-=pdJA
------END PGP SIGNATURE-----
+MD5 f8967397e1d9508b8cc6df9fc17a0e75 files/digest-urwid-0.8.7 62
diff --git a/dev-python/urwid/files/digest-urwid-0.8.7 b/dev-python/urwid/files/digest-urwid-0.8.7
new file mode 100644
index 000000000000..0bc1d7c9d687
--- /dev/null
+++ b/dev-python/urwid/files/digest-urwid-0.8.7
@@ -0,0 +1 @@
+MD5 77ab93284f4971e2fa39ab9b3ddb8003 urwid-0.8.7.tar.gz 76918
diff --git a/dev-python/urwid/urwid-0.8.7.ebuild b/dev-python/urwid/urwid-0.8.7.ebuild
new file mode 100644
index 000000000000..c3e6c04136e0
--- /dev/null
+++ b/dev-python/urwid/urwid-0.8.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.8.7.ebuild,v 1.1 2005/05/10 00:29:42 pythonhead Exp $
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins browse.py dialog.py edit.py calc.py fib.py tour.py
+ fi
+}