summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-09 17:20:30 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-09 17:20:30 +0000
commita0a553cb19ebdaaf2fbc156f17fc5596fa12928d (patch)
treeaac5c5a50569c32b0f9bbb1d50c2cbf14dc5219d /dev-python/urllib3
parentbump (diff)
downloadgentoo-2-a0a553cb19ebdaaf2fbc156f17fc5596fa12928d.tar.gz
gentoo-2-a0a553cb19ebdaaf2fbc156f17fc5596fa12928d.tar.bz2
gentoo-2-a0a553cb19ebdaaf2fbc156f17fc5596fa12928d.zip
bump; added pypy support, fix to setup.cfg -> fixes testsuite, fixes Bug #468236
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/ChangeLog8
-rw-r--r--dev-python/urllib3/urllib3-1.6.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/urllib3/ChangeLog b/dev-python/urllib3/ChangeLog
index 92f221a2ee1d..f858bee1a7d1 100644
--- a/dev-python/urllib3/ChangeLog
+++ b/dev-python/urllib3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urllib3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.5 2013/03/25 16:41:11 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/ChangeLog,v 1.6 2013/05/09 17:20:30 idella4 Exp $
+
+*urllib3-1.6 (09 May 2013)
+
+ 09 May 2013; Ian Delaney <idella4@gentoo.org> +urllib3-1.6.ebuild:
+ bump; added pypy support, fix to setup.cfg -> fixes testsuite, fixes Bug
+ #468236
*urllib3-1.5-r1 (25 Mar 2013)
diff --git a/dev-python/urllib3/urllib3-1.6.ebuild b/dev-python/urllib3/urllib3-1.6.ebuild
new file mode 100644
index 000000000000..d9566d65c8bf
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urllib3/urllib3-1.6.ebuild,v 1.1 2013/05/09 17:20:30 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/shazow/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=www-servers/tornado-2.4.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # Replace bundled copy of dev-python/six
+ cat > urllib3/packages/six.py <<-EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+
+ sed -i -e "s/'dummyserver',//" setup.py || die
+ sed -e 's:cover-min-percentage = 100::' -i setup.cfg || die
+
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ local test
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}