summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 14:22:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 14:22:35 +0000
commit37679faa86866a95a06c0e2299a85a492ba94395 (patch)
tree20f2be6c932894eb1a9a81b8b826eafe397dda86 /dev-python/twistedsnmp
parentRemove ruby19 from USE_RUBY since it does not build with Ruby 1.9. (diff)
downloadgentoo-2-37679faa86866a95a06c0e2299a85a492ba94395.tar.gz
gentoo-2-37679faa86866a95a06c0e2299a85a492ba94395.tar.bz2
gentoo-2-37679faa86866a95a06c0e2299a85a492ba94395.zip
Bump to 0.3.12
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twistedsnmp')
-rw-r--r--dev-python/twistedsnmp/ChangeLog10
-rw-r--r--dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild4
-rw-r--r--dev-python/twistedsnmp/twistedsnmp-0.3.12.ebuild29
3 files changed, 39 insertions, 4 deletions
diff --git a/dev-python/twistedsnmp/ChangeLog b/dev-python/twistedsnmp/ChangeLog
index 8823b2df0c10..c6bb8b841012 100644
--- a/dev-python/twistedsnmp/ChangeLog
+++ b/dev-python/twistedsnmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twistedsnmp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.4 2007/02/22 00:52:36 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/ChangeLog,v 1.5 2009/02/15 14:22:35 patrick Exp $
+
+*twistedsnmp-0.3.12 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org>
+ +twistedsnmp-0.3.12.ebuild:
+ Bump to 0.3.12
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild b/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild
index 09646d565a2b..45605d0542b1 100644
--- a/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild
+++ b/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild,v 1.4 2007/02/03 09:16:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.2.9.ebuild,v 1.5 2009/02/15 14:22:35 patrick Exp $
inherit distutils
MY_PN="TwistedSNMP"
diff --git a/dev-python/twistedsnmp/twistedsnmp-0.3.12.ebuild b/dev-python/twistedsnmp/twistedsnmp-0.3.12.ebuild
new file mode 100644
index 000000000000..a19c718f74a8
--- /dev/null
+++ b/dev-python/twistedsnmp/twistedsnmp-0.3.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.12.ebuild,v 1.1 2009/02/15 14:22:35 patrick Exp $
+
+inherit distutils
+MY_PN="TwistedSNMP"
+MY_PV="${PV}" # change when version has an a1 or similar extension
+
+DESCRIPTION="SNMP protocols and APIs for use with the Twisted networking framework"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0" # should only be the one version installed
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+IUSE=""
+DEPEND="virtual/python
+ >=dev-python/pysnmp-3.0.0
+ >=dev-python/twisted-1.3"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_install() {
+ distutils_src_install
+ dohtml doc/index.html
+ insinto /usr/share/doc/${PF}/html/style/
+ doins doc/style/sitestyle.css
+}