summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-04-18 15:45:23 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-04-18 15:45:23 +0000
commita384a6e1b5d51be1d08ad75131333ed4a4eca675 (patch)
tree65ee60d898adf266c8d67b441ffa5ea8f398778a /dev-python/twisted
parentunmasked, repoman compliant (diff)
downloadgentoo-2-a384a6e1b5d51be1d08ad75131333ed4a4eca675.tar.gz
gentoo-2-a384a6e1b5d51be1d08ad75131333ed4a4eca675.tar.bz2
gentoo-2-a384a6e1b5d51be1d08ad75131333ed4a4eca675.zip
new version
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.41
-rw-r--r--dev-python/twisted/twisted-1.0.4.ebuild42
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index d04961421da3..3e6a5b1786a7 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.16 2003/04/10 22:14:01 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.17 2003/04/18 15:45:23 lordvan Exp $
+*twisted-1.0.4 (18 Apr 2003)
+ 18 Apr 2003; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.0.4.ebuild
+ new version
+
*twisted-1.0.3-r1 (10 Apr 2003)
10 Apr 2003; Alastair Tse <liquidx@gentoo.org> twisted-1.0.3-r1.ebuild:
diff --git a/dev-python/twisted/files/digest-twisted-1.0.4 b/dev-python/twisted/files/digest-twisted-1.0.4
new file mode 100644
index 000000000000..d46e34e523ab
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.4
@@ -0,0 +1 @@
+MD5 03f943e0c960d3b94e7e113a9f49b1d0 Twisted-1.0.4.tar.bz2 4173463
diff --git a/dev-python/twisted/twisted-1.0.4.ebuild b/dev-python/twisted/twisted-1.0.4.ebuild
new file mode 100644
index 000000000000..a9dbd6c30a06
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.4.ebuild,v 1.1 2003/04/18 15:45:23 lordvan Exp $
+
+IUSE="gtk2 doc"
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk2? ( =dev-python/pygtk-0.6* ) : ( >=dev-python/pygtk-1.99 )"
+KEYWORDS="~x86 ~alpha ~sparc "
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+
+}
+