summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-10 22:14:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-10 22:14:10 +0000
commit701487cd102f36c0c0ab2fca0f477a62e0d76ae6 (patch)
tree0897ab57211037256d6667949b9e91a65ae297c4 /dev-python/twisted
parentadd pygtk deps (diff)
downloadgentoo-2-701487cd102f36c0c0ab2fca0f477a62e0d76ae6.tar.gz
gentoo-2-701487cd102f36c0c0ab2fca0f477a62e0d76ae6.tar.bz2
gentoo-2-701487cd102f36c0c0ab2fca0f477a62e0d76ae6.zip
add pygtk deps
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/Manifest4
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.3-r11
-rw-r--r--dev-python/twisted/twisted-1.0.3-r1.ebuild42
4 files changed, 51 insertions, 3 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 8609552f0dc0..d04961421da3 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.15 2003/04/04 23:59:12 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.16 2003/04/10 22:14:01 liquidx Exp $
+
+*twisted-1.0.3-r1 (10 Apr 2003)
+
+ 10 Apr 2003; Alastair Tse <liquidx@gentoo.org> twisted-1.0.3-r1.ebuild:
+ added pygtk deps, and fix manhole to use pygtk2 is requested
*twisted-1.0.3 (16 Feb 2003)
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 2331cd5a265b..e75d875d7f36 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,8 +1,8 @@
-MD5 1e9979d4b31c1b1f739d50dace7a4097 ChangeLog 5322
+MD5 028883ce8556db8bf852795160f12cb2 ChangeLog 5322
MD5 a292cc4da12ab047112cb1d1c924974d twisted-1.0.1-r1.ebuild 1045
MD5 d06471a8cd5ee9b2b656271b78666209 twisted-1.0.2.ebuild 1043
MD5 964cfc6aed5e04485cd18e27d9632f0e twisted-1.0.3.ebuild 1027
-MD5 d5cee98a24ee3f1eb23c651a07fc4878 twisted-1.0.3-r1.ebuild 1237
+MD5 0b8d7fec24e05abd550c9e80e7eb6b96 twisted-1.0.3-r1.ebuild 1240
MD5 bb7d3ef16b63fe638cc8becd30eede88 files/digest-twisted-1.0.3-r1 67
MD5 962cfda0434627ad4e3e6780175833a7 files/digest-twisted-1.0.1-r1 67
MD5 a10d97e929ad363df80f670b7579f2a6 files/digest-twisted-1.0.2 67
diff --git a/dev-python/twisted/files/digest-twisted-1.0.3-r1 b/dev-python/twisted/files/digest-twisted-1.0.3-r1
new file mode 100644
index 000000000000..497271b01ba3
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.3-r1
@@ -0,0 +1 @@
+MD5 01f24f2329d6320ba26f38aa880feba3 Twisted-1.0.3.tar.bz2 3637666
diff --git a/dev-python/twisted/twisted-1.0.3-r1.ebuild b/dev-python/twisted/twisted-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..c160d9ad037d
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.3-r1.ebuild,v 1.1 2003/04/10 22:14:01 liquidx Exp $
+
+IUSE="gtk2 doc"
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk2? ( =dev-python/pygtk-0.6* ) : ( >=dev-python/pygtk-1.99 )"
+KEYWORDS="~x86 ~alpha ~sparc "
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+
+}
+