summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-04-09 23:39:19 +0000
committerMarien Zwart <marienz@gentoo.org>2006-04-09 23:39:19 +0000
commiteb577aac1a25c6a76391481122020d40c8d986ce (patch)
treed792a031f1cb4b59a2cc791eefed568aa99038e5 /dev-python/twisted/twisted-2.2.0.ebuild
parentVersion bump, closes bug 121958. (diff)
downloadgentoo-2-eb577aac1a25c6a76391481122020d40c8d986ce.tar.gz
gentoo-2-eb577aac1a25c6a76391481122020d40c8d986ce.tar.bz2
gentoo-2-eb577aac1a25c6a76391481122020d40c8d986ce.zip
Add PYTHONPATH to tests to make them work without userpriv in FEATURES.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-python/twisted/twisted-2.2.0.ebuild')
-rw-r--r--dev-python/twisted/twisted-2.2.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/twisted/twisted-2.2.0.ebuild b/dev-python/twisted/twisted-2.2.0.ebuild
index 7a320b547c74..25ef4ab19b99 100644
--- a/dev-python/twisted/twisted-2.2.0.ebuild
+++ b/dev-python/twisted/twisted-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.2.0.ebuild,v 1.3 2006/04/03 21:16:14 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.2.0.ebuild,v 1.4 2006/04/09 23:39:19 marienz Exp $
inherit eutils distutils versionator
@@ -101,7 +101,7 @@ src_test() {
# docstrings in all packages
echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
- "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ PYTHONPATH=. "${T}"/tests/usr/bin/trial twisted || die "trial failed"
cd "${S}"
rm -rf "${T}/tests"
}