summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-26 00:43:27 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-26 00:43:27 +0000
commitf694a6d8b299fb38f4ebb2fe8d494e8e17c394fb (patch)
tree42190fab8ffe060e65172d6a2a902e9df47a54a1 /dev-python/twisted-core
parentConvert DOCS to an array, bug 482230. (diff)
downloadgentoo-2-f694a6d8b299fb38f4ebb2fe8d494e8e17c394fb.tar.gz
gentoo-2-f694a6d8b299fb38f4ebb2fe8d494e8e17c394fb.tar.bz2
gentoo-2-f694a6d8b299fb38f4ebb2fe8d494e8e17c394fb.zip
Install missing egg-info file, bug 428478.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/twisted-core')
-rw-r--r--dev-python/twisted-core/ChangeLog8
-rw-r--r--dev-python/twisted-core/twisted-core-13.0.0-r2.ebuild (renamed from dev-python/twisted-core/twisted-core-13.0.0-r1.ebuild)10
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-python/twisted-core/ChangeLog b/dev-python/twisted-core/ChangeLog
index df8a16cee061..739749d73e91 100644
--- a/dev-python/twisted-core/ChangeLog
+++ b/dev-python/twisted-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/ChangeLog,v 1.5 2013/08/23 12:56:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/ChangeLog,v 1.6 2013/08/26 00:43:27 floppym Exp $
+
+*twisted-core-13.0.0-r2 (26 Aug 2013)
+
+ 26 Aug 2013; Mike Gilbert <floppym@gentoo.org> +twisted-core-13.0.0-r2.ebuild,
+ -twisted-core-13.0.0-r1.ebuild:
+ Install missing egg-info file, bug 428478.
23 Aug 2013; Jeroen Roovers <jer@gentoo.org> twisted-core-12.3.0.ebuild:
Stable for HPPA (bug #468150).
diff --git a/dev-python/twisted-core/twisted-core-13.0.0-r1.ebuild b/dev-python/twisted-core/twisted-core-13.0.0-r2.ebuild
index 7907003a5a2e..1d3c7fd559d5 100644
--- a/dev-python/twisted-core/twisted-core-13.0.0-r1.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.0.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-13.0.0-r1.ebuild,v 1.2 2013/08/09 12:16:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-core/twisted-core-13.0.0-r2.ebuild,v 1.1 2013/08/26 00:43:27 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -89,8 +89,14 @@ python_test() {
python_install() {
distutils-r1_python_install
+ local PYTHON_SITEDIR
+ python_export PYTHON_SITEDIR
+
+ # Bug 299736
+ touch "${D%/}${PYTHON_SITEDIR}/Twisted-${PV}-py${EPYTHON#python}.egg-info"
+
# own the dropin.cache so we don't leave orphans
- touch "${D}$(python_get_sitedir)/twisted/plugins/dropin.cache" || die
+ touch "${D%/}${PYTHON_SITEDIR}/twisted/plugins/dropin.cache" || die
}
python_install_all() {