summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-01-02 15:17:55 +0000
committerIan Delaney <idella4@gentoo.org>2014-01-02 15:17:55 +0000
commitbbc7b68c4aa8ce8fe8c0d964ebe93a4effcba37b (patch)
tree4244487fdc5dd0dde57d9e487904c42163e7ee98 /dev-python/testrepository/testrepository-0.0.18.ebuild
parentfixing typo in previous commit, helps to actually have -j1 (diff)
downloadgentoo-2-bbc7b68c4aa8ce8fe8c0d964ebe93a4effcba37b.tar.gz
gentoo-2-bbc7b68c4aa8ce8fe8c0d964ebe93a4effcba37b.tar.bz2
gentoo-2-bbc7b68c4aa8ce8fe8c0d964ebe93a4effcba37b.zip
tidy up, remove old, revbump; add py3 & pypy support, upgraded accordingly, bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testrepository/testrepository-0.0.18.ebuild')
-rw-r--r--dev-python/testrepository/testrepository-0.0.18.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.18.ebuild b/dev-python/testrepository/testrepository-0.0.18.ebuild
new file mode 100644
index 000000000000..8da88bf5eb4e
--- /dev/null
+++ b/dev-python/testrepository/testrepository-0.0.18.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testrepository/testrepository-0.0.18.ebuild,v 1.1 2014/01/02 15:17:55 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A repository of test results."
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/testresources[$(python_gen_usedep python{2_7,3_2})]
+ dev-python/testscenarios[$(python_gen_usedep python{2_7,3_2})]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+#bzr is listed but presumably req'd for a live repo test run
+RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
+
+REQUIRED_USE="test? ( $(python_gen_useflags python{2_7,3_2}) )"
+
+python_test() {
+ # The running has a gentoo python style bug, yet unknown, that corrupts the passing of
+ # impls other than py2.7. A wip
+ if [ "${EPYTHON}" == python2.7 ]; then
+ "${PYTHON}" ./testr init || die
+ "${PYTHON}" ./testr run || die "tests failed under ${EPYTHON}"
+ fi
+}