summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 08:10:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 08:10:39 +0000
commitc505f9c5510257015c98acacd73d24edbc0c6479 (patch)
tree3fb400a450fd2a59504bb4a7d7ece2e70accb285 /dev-python/testify
parentfix init script user and group execution (diff)
downloadgentoo-2-c505f9c5510257015c98acacd73d24edbc0c6479.tar.gz
gentoo-2-c505f9c5510257015c98acacd73d24edbc0c6479.tar.bz2
gentoo-2-c505f9c5510257015c98acacd73d24edbc0c6479.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/ChangeLog7
-rw-r--r--dev-python/testify/testify-0.3.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index f0894d3c28ef..03c15f24767c 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.11 2014/05/20 15:16:08 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.12 2014/05/26 08:10:39 patrick Exp $
+
+*testify-0.3.2 (26 May 2014)
+
+ 26 May 2014; Patrick Lauer <patrick@gentoo.org> +testify-0.3.2.ebuild:
+ Bump
*testify-0.3.1 (20 May 2014)
diff --git a/dev-python/testify/testify-0.3.2.ebuild b/dev-python/testify/testify-0.3.2.ebuild
new file mode 100644
index 000000000000..2f474c2606f0
--- /dev/null
+++ b/dev-python/testify/testify-0.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.2.ebuild,v 1.1 2014/05/26 08:10:39 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+RESTRICT="test"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+DOCS="README.md"
+
+src_prepare_all() {
+ # Rm rogue test, Bug #438032
+ rm -f test/plugins//http_reporter_test.py
+}
+
+python_test() {
+ "${PYTHON}" bin/${PN} test || die
+}