summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-27 08:55:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-27 08:55:20 +0000
commit64e7c8c5b04afea96bf4b7cf18a5786f0361bcc4 (patch)
treeece08b2a1601816af58b1101e0cc63988fc48a56 /dev-python/testify
parentFix building against sys-kernel/linux-headers-3.17 (bug #526946 by Gangræna ... (diff)
downloadgentoo-2-64e7c8c5b04afea96bf4b7cf18a5786f0361bcc4.tar.gz
gentoo-2-64e7c8c5b04afea96bf4b7cf18a5786f0361bcc4.tar.bz2
gentoo-2-64e7c8c5b04afea96bf4b7cf18a5786f0361bcc4.zip
bump; rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/ChangeLog10
-rw-r--r--dev-python/testify/testify-0.3.0.ebuild37
-rw-r--r--dev-python/testify/testify-0.3.1.ebuild36
-rw-r--r--dev-python/testify/testify-0.3.2.ebuild36
-rw-r--r--dev-python/testify/testify-0.3.3.ebuild36
-rw-r--r--dev-python/testify/testify-0.3.4.ebuild36
-rw-r--r--dev-python/testify/testify-0.3.5.ebuild38
-rw-r--r--dev-python/testify/testify-0.3.6.ebuild39
-rw-r--r--dev-python/testify/testify-0.5.6.ebuild (renamed from dev-python/testify/testify-0.3.7.ebuild)7
9 files changed, 11 insertions, 264 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index 9bfe208ba8a9..f73decf7519c 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.17 2014/10/15 11:36:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.18 2014/10/27 08:55:20 idella4 Exp $
+
+*testify-0.5.6 (27 Oct 2014)
+
+ 27 Oct 2014; Ian Delaney <idella4@gentoo.org> +testify-0.5.6.ebuild,
+ -testify-0.3.0.ebuild, -testify-0.3.1.ebuild, -testify-0.3.2.ebuild,
+ -testify-0.3.3.ebuild, -testify-0.3.4.ebuild, -testify-0.3.5.ebuild,
+ -testify-0.3.6.ebuild, -testify-0.3.7.ebuild:
+ bump; rm old
*testify-0.3.7 (15 Oct 2014)
diff --git a/dev-python/testify/testify-0.3.0.ebuild b/dev-python/testify/testify-0.3.0.ebuild
deleted file mode 100644
index 644ab7387f7f..000000000000
--- a/dev-python/testify/testify-0.3.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.0.ebuild,v 1.2 2014/05/20 15:16:08 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-src_prepare_all() {
- # Rm rogue test, Bug #438032
- rm -f test/plugins//http_reporter_test.py
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.1.ebuild b/dev-python/testify/testify-0.3.1.ebuild
deleted file mode 100644
index e9ca56b9e742..000000000000
--- a/dev-python/testify/testify-0.3.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.1.ebuild,v 1.1 2014/05/20 15:16:08 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-src_prepare_all() {
- # Rm rogue test, Bug #438032
- rm -f test/plugins//http_reporter_test.py
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.2.ebuild b/dev-python/testify/testify-0.3.2.ebuild
deleted file mode 100644
index 2f474c2606f0..000000000000
--- a/dev-python/testify/testify-0.3.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.2.ebuild,v 1.1 2014/05/26 08:10:39 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-RESTRICT="test"
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-src_prepare_all() {
- # Rm rogue test, Bug #438032
- rm -f test/plugins//http_reporter_test.py
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.3.ebuild b/dev-python/testify/testify-0.3.3.ebuild
deleted file mode 100644
index 9ea00c7510e9..000000000000
--- a/dev-python/testify/testify-0.3.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.3.ebuild,v 1.1 2014/06/03 10:53:39 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-RESTRICT="test" # basically broken
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-src_prepare_all() {
- # Rm rogue test, Bug #438032
- rm -f test/plugins//http_reporter_test.py
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.4.ebuild b/dev-python/testify/testify-0.3.4.ebuild
deleted file mode 100644
index 090bb0d94661..000000000000
--- a/dev-python/testify/testify-0.3.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.4.ebuild,v 1.1 2014/06/17 06:35:30 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-RESTRICT="test" # basically broken
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-src_prepare_all() {
- # Rm rogue test, Bug #438032
- rm -f test/plugins//http_reporter_test.py
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.5.ebuild b/dev-python/testify/testify-0.3.5.ebuild
deleted file mode 100644
index dd932470e2e3..000000000000
--- a/dev-python/testify/testify-0.3.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.5.ebuild,v 1.1 2014/07/24 10:12:30 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-RESTRICT="test" # basically very broken
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-DOCS="README.md"
-
-python_prepare_all() {
- # Correct typo in setup.py
- sed -e 's:mock,:mock:' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.6.ebuild b/dev-python/testify/testify-0.3.6.ebuild
deleted file mode 100644
index d1d4146195af..000000000000
--- a/dev-python/testify/testify-0.3.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.6.ebuild,v 1.1 2014/08/28 16:46:43 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-#RESTRICT="test" # basically very broken
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A more pythonic replacement for the unittest module and nose"
-HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-# There is another undocumented dep req'd for the testsuite; catbox
-DOCS="README.md"
-
-python_prepare_all() {
- # Correct typo in setup.py
- sed -e 's:mock,:mock:' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # https://github.com/Yelp/Testify/issues/283
- "${PYTHON}" bin/${PN} test || die
-}
diff --git a/dev-python/testify/testify-0.3.7.ebuild b/dev-python/testify/testify-0.5.6.ebuild
index 81bb1790cbac..3b7c3b3d20de 100644
--- a/dev-python/testify/testify-0.3.7.ebuild
+++ b/dev-python/testify/testify-0.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.7.ebuild,v 1.1 2014/10/15 11:36:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.5.6.ebuild,v 1.1 2014/10/27 08:55:20 idella4 Exp $
EAPI=5
@@ -12,7 +12,7 @@ inherit distutils-r1 vcs-snapshot
DESCRIPTION="A more pythonic replacement for the unittest module and nose"
HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
-SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -26,9 +26,6 @@ RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} )"
-# There is another undocumented dep req'd for the testsuite; catbox
-DOCS="README.md"
-
python_prepare_all() {
# Correct typo in setup.py
sed -e 's:mock,:mock:' -i setup.py || die