summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-30 08:18:54 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-30 08:18:54 +0000
commit5fc671cb7288a2eb6ceff4bd3c5236613a4fea49 (patch)
tree0934ca5568e1d01d745f84976a88c0b428251638 /dev-python/testfixtures
parentAdd ~mips keyword (diff)
downloadgentoo-2-5fc671cb7288a2eb6ceff4bd3c5236613a4fea49.tar.gz
gentoo-2-5fc671cb7288a2eb6ceff4bd3c5236613a4fea49.tar.bz2
gentoo-2-5fc671cb7288a2eb6ceff4bd3c5236613a4fea49.zip
drop py2.6, update deps, docbuild (includes new patch), remove old ebuild and patch, fixes bug #515752 by Patrick
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/ChangeLog8
-rw-r--r--dev-python/testfixtures/files/docbuild.patch25
-rw-r--r--dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch130
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild50
-rw-r--r--dev-python/testfixtures/testfixtures-3.0.0.ebuild24
5 files changed, 44 insertions, 193 deletions
diff --git a/dev-python/testfixtures/ChangeLog b/dev-python/testfixtures/ChangeLog
index 30a29e4a8465..8d804a35e224 100644
--- a/dev-python/testfixtures/ChangeLog
+++ b/dev-python/testfixtures/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testfixtures
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.7 2014/03/19 23:10:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.8 2014/06/30 08:18:54 idella4 Exp $
+
+ 30 Jun 2014; Ian Delaney <idella4@gentoo.org> +files/docbuild.patch,
+ -files/testfixtures-2.3.4-adjust_tests.patch, -testfixtures-2.3.4.ebuild,
+ testfixtures-3.0.0.ebuild:
+ drop py2.6, update deps, docbuild (includes new patch), remove old ebuild and
+ patch, fixes bug #515752 by Patrick
19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> testfixtures-3.0.0.ebuild:
Keyword ~amd64-linux ~x86-linux
diff --git a/dev-python/testfixtures/files/docbuild.patch b/dev-python/testfixtures/files/docbuild.patch
new file mode 100644
index 000000000000..dcdef3270545
--- /dev/null
+++ b/dev-python/testfixtures/files/docbuild.patch
@@ -0,0 +1,25 @@
+diff -ur testfixtures-3.0.0.orig/docs/conf.py testfixtures-3.0.0/docs/conf.py
+--- docs/conf.py 2011-09-23 16:55:53.000000000 +0800
++++ docs/conf.py 2014-06-30 15:36:43.591451878 +0800
+@@ -4,8 +4,7 @@
+ pkg_info = pkginfo.Develop(os.path.join(os.path.dirname(__file__),'..'))
+
+ extensions = [
+- 'sphinx.ext.autodoc',
+- 'sphinx.ext.intersphinx'
++ 'sphinx.ext.autodoc'
+ ]
+
+ intersphinx_mapping = {'http://docs.python.org': None}
+diff -ur testfixtures-3.0.0.orig/docs/Makefile testfixtures-3.0.0/docs/Makefile
+--- docs/Makefile 2011-07-19 00:43:59.000000000 +0800
++++ docs/Makefile 2014-06-30 15:36:31.703450934 +0800
+@@ -3,7 +3,7 @@
+
+ # You can set these variables from the command line.
+ SPHINXOPTS =
+-SPHINXBUILD = ../bin/sphinx-build
++SPHINXBUILD = /usr/bin/sphinx-build
+ PAPER =
+
+ # Internal variables.
diff --git a/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch b/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
deleted file mode 100644
index 590bb796b7b7..000000000000
--- a/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_comparison.py testfixtures-2.3.4/testfixtures/tests/test_comparison.py
---- testfixtures/tests/test_comparison.py 2012-01-26 18:00:05.000000000 +0800
-+++ testfixtures/tests/test_comparison.py 2012-04-13 19:00:15.856224293 +0800
-@@ -5,7 +5,7 @@
- from testfixtures.tests.sample1 import TestClassA,a_function
- from unittest import TestCase,TestSuite,makeSuite
-
--from .compat import py_27_plus
-+from compat import py_27_plus
-
- class AClass:
-
-diff -ur testfixtures-2.3.4.orig/tests/test_components.py testfixtures-2.3.4/testfixtures/tests/test_components.py
---- testfixtures/tests/test_components.py 2012-01-27 02:41:51.000000000 +0800
-+++ testfixtures/tests/test_components.py 2012-04-13 19:08:44.434220585 +0800
-@@ -14,7 +14,7 @@
- from testfixtures import compare
- from unittest import TestCase
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class ComponentsTests(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_docs.py testfixtures-2.3.4/testfixtures/tests/test_docs.py
---- testfixtures/tests/test_docs.py 2012-01-28 16:07:57.000000000 +0800
-+++ testfixtures/tests/test_docs.py 2012-04-13 19:03:36.649223003 +0800
-@@ -11,7 +11,7 @@
-
- import os
-
--from . import compat
-+import compat
-
- workspace = os.environ.get('WORKSPACE', join(dirname(__file__), pardir, pardir))
- tests = glob(join(workspace,'docs', '*.txt'))
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_logcapture.py testfixtures-2.3.4/testfixtures/tests/test_logcapture.py
---- testfixtures/tests/test_logcapture.py 2012-01-27 02:41:26.000000000 +0800
-+++ testfixtures/tests/test_logcapture.py 2012-04-13 19:09:02.930220838 +0800
-@@ -10,7 +10,7 @@
-
- from logging import getLogger
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- root = getLogger()
- one = getLogger('one')
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_replace.py testfixtures-2.3.4/testfixtures/tests/test_replace.py
---- testfixtures/tests/test_replace.py 2012-01-27 02:34:12.000000000 +0800
-+++ testfixtures/tests/test_replace.py 2012-04-13 19:09:18.842220416 +0800
-@@ -17,7 +17,7 @@
- import sample1
- import sample2
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class TestReplace(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_should_raise.py testfixtures-2.3.4/testfixtures/tests/test_should_raise.py
---- testfixtures/tests/test_should_raise.py 2012-01-27 02:43:51.000000000 +0800
-+++ testfixtures/tests/test_should_raise.py 2012-04-13 19:09:36.235220628 +0800
-@@ -5,7 +5,7 @@
- from testfixtures import should_raise,ShouldRaise,Comparison as C
- from unittest import TestCase,TestSuite,makeSuite
-
--from .compat import py_27_plus
-+from compat import py_27_plus
-
- class TestShouldRaise(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_tempdirectory.py testfixtures-2.3.4/testfixtures/tests/test_tempdirectory.py
---- testfixtures/tests/test_tempdirectory.py 2012-01-27 02:25:43.000000000 +0800
-+++ testfixtures/tests/test_tempdirectory.py 2012-04-13 19:09:54.971220623 +0800
-@@ -13,7 +13,7 @@
-
- from logging import getLogger
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class DemoTempDirectory:
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_manuel_examples.py testfixtures-2.3.4/testfixtures/tests/test_manuel_examples.py
---- testfixtures/tests/test_manuel_examples.py 2012-01-26 04:31:12.000000000 +0800
-+++ testfixtures/tests/test_manuel_examples.py 2012-04-13 21:14:05.390172684 +0800
-@@ -11,7 +11,7 @@
- from testfixtures import TempDirectory
- from testfixtures.manuel import Files
-
--from . import compat
-+import compat
-
- def setUp(test):
- test.globs['tempdir']=TempDirectory()
-diff -ur testfixtures-2.3.4.orig/testfixtures/components.py testfixtures-2.3.4/testfixtures/components.py
---- testfixtures/components.py 2011-10-12 00:21:45.000000000 +0800
-+++ testfixtures/components.py 2012-04-29 18:12:41.891588669 +0800
-@@ -4,8 +4,8 @@
- import atexit
- import warnings
-
--from zope.component import getSiteManager
--from zope.component.registry import Components
-+#from zope.component import getSiteManager
-+#from zope.component.registry import Components
-
- class TestComponents:
- """
-@@ -20,11 +20,8 @@
- atexit_setup = False
-
- def __init__(self):
-- self.registry = Components('Testing')
-- self.old = getSiteManager.sethook(lambda:self.registry)
- self.instances.add(self)
- if not self.__class__.atexit_setup:
-- atexit.register(self.atexit)
- self.__class__.atexit_setup = True
-
- def uninstall(self):
-@@ -33,7 +30,6 @@
- was in place before this :class:`TestComponents` was
- instantiated.
- """
-- getSiteManager.sethook(self.old)
- self.instances.remove(self)
-
- @classmethod
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
deleted file mode 100644
index 16561c171e58..000000000000
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-2.3.4.ebuild,v 1.3 2013/03/15 20:58:09 idella4 Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-DISTUTILS_SRC_TEST="py.test"
-inherit distutils eutils
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
- test? ( dev-python/manuel )"
-
-src_prepare() {
- sed -e s':../bin/sphinx-build:/usr/bin/sphinx-build:' \
- -i docs/Makefile || die
- epatch "${FILESDIR}"/${P}-adjust_tests.patch
-
- # remove test that tests the stripped zope-component test_components.ComponentsTests
- rm -f testfixtures/tests/test_components.py || die
- distutils_src_prepare
-}
-src_compile() {
- distutils_src_compile
-
- use doc && emake -C docs html
-}
-
-src_test() {
- distutils_src_test ${PN}/tests/
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-}
diff --git a/dev-python/testfixtures/testfixtures-3.0.0.ebuild b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
index b107ab52d01d..f3b966fd0519 100644
--- a/dev-python/testfixtures/testfixtures-3.0.0.ebuild
+++ b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-3.0.0.ebuild,v 1.3 2014/03/19 23:10:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-3.0.0.ebuild,v 1.4 2014/06/30 08:18:54 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
inherit distutils-r1
@@ -16,18 +16,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+DEPEND=" dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7) )
test? ( dev-python/manuel[${PYTHON_USEDEP}] )"
-src_prepare() {
- sed -e s':../bin/sphinx-build:/usr/bin/sphinx-build:' \
- -i docs/Makefile || die
+# Prevent un-needed download during build, fix Makefile for doc build
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+python_prepare() {
# remove test that tests the stripped zope-component test_components.ComponentsTests
rm -f testfixtures/tests/test_components.py || die
- distutils-r1_src_prepare
+
+ distutils-r1_python_prepare
}
python_compile_all() {
@@ -39,7 +40,6 @@ python_test() {
}
python_install_all() {
- if use doc; then
- dohtml -r docs/_build/html/
- fi
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
}