summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-03-23 15:19:12 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-03-23 15:19:12 +0000
commita53f8ed5845a92bcc5a2c62abf04968ce8bc3203 (patch)
treed7fdde8c1a1534bce80eb589f988e0216bce81ad /dev-python/tempest-lib
parentbumping olso-log (diff)
downloadgentoo-2-a53f8ed5845a92bcc5a2c62abf04968ce8bc3203.tar.gz
gentoo-2-a53f8ed5845a92bcc5a2c62abf04968ce8bc3203.tar.bz2
gentoo-2-a53f8ed5845a92bcc5a2c62abf04968ce8bc3203.zip
bup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/tempest-lib')
-rw-r--r--dev-python/tempest-lib/ChangeLog8
-rw-r--r--dev-python/tempest-lib/tempest-lib-0.4.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/tempest-lib/ChangeLog b/dev-python/tempest-lib/ChangeLog
index b0cdf4fa00b9..d0d2704bb5ca 100644
--- a/dev-python/tempest-lib/ChangeLog
+++ b/dev-python/tempest-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/tempest-lib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tempest-lib/ChangeLog,v 1.1 2015/02/28 07:06:17 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tempest-lib/ChangeLog,v 1.2 2015/03/23 15:19:12 prometheanfire Exp $
+
+*tempest-lib-0.4.0 (23 Mar 2015)
+
+ 23 Mar 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +tempest-lib-0.4.0.ebuild:
+ bup
*tempest-lib-0.3.0 (28 Feb 2015)
diff --git a/dev-python/tempest-lib/tempest-lib-0.4.0.ebuild b/dev-python/tempest-lib/tempest-lib-0.4.0.ebuild
new file mode 100644
index 000000000000..b5d269fde3d2
--- /dev/null
+++ b/dev-python/tempest-lib/tempest-lib-0.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tempest-lib/tempest-lib-0.4.0.ebuild,v 1.1 2015/03/23 15:19:12 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to assist in creating functional or integrated test suites for OpenStack projects."
+HOMEPAGE="http://pypi.python.org/pypi/tempest-lib https://github.com/openstack/tempest-lib"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-0.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tempest_lib/tests || die "Tests fail with ${EPYTHON}"
+}