summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-07-21 11:42:29 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-07-21 11:42:29 +0000
commitf635bcd3a106293034c6d72965505250d4159b70 (patch)
treed5348f8b9a6f5f8df3879e81a85f1fe6effb99f9 /dev-python/subvertpy
parentRemoved no longer needed patches. Now firefox-3.6.7 should hoepfully pass the... (diff)
downloadgentoo-2-f635bcd3a106293034c6d72965505250d4159b70.tar.gz
gentoo-2-f635bcd3a106293034c6d72965505250d4159b70.tar.bz2
gentoo-2-f635bcd3a106293034c6d72965505250d4159b70.zip
Version bump dev-python/subvertpy to 0.7.3.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/ChangeLog7
-rw-r--r--dev-python/subvertpy/subvertpy-0.7.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index a6406e4f4135..505fc9d4d2ea 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.15 2010/06/22 18:38:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.16 2010/07/21 11:42:29 djc Exp $
+
+*subvertpy-0.7.3 (21 Jul 2010)
+
+ 21 Jul 2010; Dirkjan Ochtman <djc@gentoo.org> +subvertpy-0.7.3.ebuild:
+ Version bump to 0.7.3 (hgsubversion support).
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
subvertpy-0.7.2.ebuild:
diff --git a/dev-python/subvertpy/subvertpy-0.7.3.ebuild b/dev-python/subvertpy/subvertpy-0.7.3.ebuild
new file mode 100644
index 000000000000..dbad9143e4c0
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.7.3.ebuild,v 1.1 2010/07/21 11:42:29 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion."
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4
+ !<dev-util/bzr-svn-0.5.0_rc2"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}