summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-19 17:03:34 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-19 17:03:34 +0000
commitfcd1c672bf603b2877e5ae9cb0643505bc6bd66a (patch)
tree6184afdf86a1848c68f3972d3f1db6352908d26f /dev-python/subunit
parentVersion bump. (diff)
downloadgentoo-2-fcd1c672bf603b2877e5ae9cb0643505bc6bd66a.tar.gz
gentoo-2-fcd1c672bf603b2877e5ae9cb0643505bc6bd66a.tar.bz2
gentoo-2-fcd1c672bf603b2877e5ae9cb0643505bc6bd66a.zip
Version bump for bug 415233. Enable python 3. Thanks to Ian Delaney for the heads-up on missing files.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog8
-rw-r--r--dev-python/subunit/subunit-0.0.8.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index df44548b297d..78480429372b 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.15 2012/05/04 15:12:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.16 2012/05/19 17:03:34 floppym Exp $
+
+*subunit-0.0.8 (19 May 2012)
+
+ 19 May 2012; Mike Gilbert <floppym@gentoo.org> +subunit-0.0.8.ebuild:
+ Version bump for bug 415233. Enable python 3. Thanks to Ian Delaney for the
+ heads-up on missing files.
04 May 2012; Patrick Lauer <patrick@gentoo.org> subunit-0.0.6.ebuild,
subunit-0.0.7.ebuild:
diff --git a/dev-python/subunit/subunit-0.0.8.ebuild b/dev-python/subunit/subunit-0.0.8.ebuild
new file mode 100644
index 000000000000..5bef148e161a
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.8.ebuild,v 1.1 2012/05/19 17:03:34 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-pypy-*" # mis-detected sitedir
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit python
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ http://dev.gentoo.org/~floppym/distfiles/${P}-missing.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.15"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+src_prepare() {
+ python_clean_py-compile_files
+ python_src_prepare
+}
+
+src_test() {
+ testing() {
+ python_convert_shebangs ${PYTHON_ABI} runtests.py || return
+ emake check
+ }
+ python_execute_function -s testing
+}
+
+pkg_postinst() {
+ python_mod_optimize subunit
+}
+
+pkg_postrm() {
+ python_mod_cleanup subunit
+}