summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-04-08 07:39:25 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-04-08 07:39:25 +0000
commita244ea60fda9a515b0dcd68c0d12cdfda44fcea3 (patch)
treebcd5fe5db8aa4932ba20ee2ca97b9371d14a3cbf /dev-python/subunit
parentVersion bump (diff)
downloadgentoo-2-a244ea60fda9a515b0dcd68c0d12cdfda44fcea3.tar.gz
gentoo-2-a244ea60fda9a515b0dcd68c0d12cdfda44fcea3.tar.bz2
gentoo-2-a244ea60fda9a515b0dcd68c0d12cdfda44fcea3.zip
initial commit by me
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog10
-rw-r--r--dev-python/subunit/metadata.xml6
-rw-r--r--dev-python/subunit/subunit-0.0.5.ebuild30
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
new file mode 100644
index 000000000000..73a4b1a7a5ce
--- /dev/null
+++ b/dev-python/subunit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/subunit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.1 2010/04/08 07:39:25 fauli Exp $
+
+*subunit-0.0.5 (08 Apr 2010)
+
+ 08 Apr 2010; Christian Faulhammer <fauli@gentoo.org>
+ +subunit-0.0.5.ebuild, +metadata.xml:
+ initial commit by me
+
diff --git a/dev-python/subunit/metadata.xml b/dev-python/subunit/metadata.xml
new file mode 100644
index 000000000000..873c7c0e54d3
--- /dev/null
+++ b/dev-python/subunit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/subunit/subunit-0.0.5.ebuild b/dev-python/subunit/subunit-0.0.5.ebuild
new file mode 100644
index 000000000000..7a99b793312b
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.5.ebuild,v 1.1 2010/04/08 07:39:25 fauli Exp $
+
+PYTHON_DEPEND="2:2.6"
+
+inherit python
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/testtools
+ dev-util/cppunit
+ dev-lang/perl
+ dev-util/pkgconfig"
+RDEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ emake install DESTDIR="${D}"|| die
+}